Login | Register For Free | Help
Search for: (Advanced)

Mailing List Archive: Cisco: NSP

ASR-1K problem with old PPPoE clients.

 

 

Cisco nsp RSS feed   Index | Next | Previous | View Threaded


aweher at gmail

Apr 23, 2012, 10:23 AM

Post #1 of 3 (979 views)
Permalink
ASR-1K problem with old PPPoE clients.

Hi folks!

I'm facing some problems with our brand new asr 1002's.

We're having some issues with the clients being migrated from the old
7200-NPEG1 to the new BRAS with the following symptoms:

The client (mostly old OSes like W2K and very old linux like debian potato)
connects successfully, got an IP address and all of the PPP parameters,
there is no traffic between the user and the net. Other users connects to
the same BRAS without problems.

This is a brief of our probes while using icmp to test the client
reachability:

BRAS -> Client [OK]
BRAS -> Client (Source interface other than Loopback) [OK]
Client -> BRAS (Any interface) [FAIL]
Client -> any IP [FAIL]
Any other host in the network -> Client [FAIL]

The routes exists in the tables of all of our routers and

Any host of the net -> BRAS (Any local interface) [OK]

The configs are very basic, like

<asr-config>
ip name-server 8.8.8.8
ip name-server 8.8.4.4
!
bba-group pppoe PPPoE
virtual-template 1
sessions per-mac limit 1
sessions per-vlan limit 16000
sessions per-mac throttle 3 30 120
sessions auto cleanup
!
interface Loopback0
description Services
ip address 200.3.M.N 255.255.255.255
ip ospf 1 area 0
!
interface Loopback110
description OSPF Sum 190.X.Y.0/24
ip address 190.X.Y.1 255.255.255.255
ip ospf 1 area 400
!
! Multiple (50+) VLAN subif's like this
!
interface GigabitEthernet0/0/2.60
description PPPoEoVLAN 60
encapsulation dot1Q 60
pppoe enable group PPPoE
!
interface Virtual-Template1
ip unnumbered Loopback0
peer default ip address pool PPPoE-POOL
ppp authentication pap
!
router ospf 1
router-id 200.3.M.N
log-adjacency-changes detail
auto-cost reference-bandwidth 10000
area 400 range 190.X.Y.0 255.255.255.0
!
ip local pool PPPoE-POOL 190.X.Y.2 190.X.Y.254
</asr config>

And the show version:

Cisco IOS Software, IOS-XE Software (PPC_LINUX_IOSD-ADVENTERPRISEK9-M),
Version 15.1(2)S, RELEASE SOFTWARE (fc1)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2011 by Cisco Systems, Inc.
Compiled Thu 24-Mar-11 23:29 by mcpre

There are several clients connected to the router and a very little part of
them doesn't get the service.

sh pppoe sum
PTA : Locally terminated sessions
FWDED: Forwarded sessions
TRANS: All other sessions (in transient state)

TOTAL PTA FWDED TRANS
TOTAL 4221 4220 0 1
GigabitEthernet0/0/2 4221 4220 0 1

The TAC has no responses to give about this problem, and it's happening in
all of our new ASR. If you have any experience about an incident like this,
please drop me a few lines.

AFAIK there is no distinction about the L2 equipment serving the customers.
If I pass the whole VLAN to our old BRAS all of the clients works fine in
the 7200 with the same config.

All of your suggestions are welcome.

Thanks for your time.

Regards.
_______________________________________________
cisco-nsp mailing list cisco-nsp [at] puck
https://puck.nether.net/mailman/listinfo/cisco-nsp
archive at http://puck.nether.net/pipermail/cisco-nsp/


mike-cisconsplist at tiedyenetworks

Apr 23, 2012, 11:14 AM

Post #2 of 3 (930 views)
Permalink
Re: ASR-1K problem with old PPPoE clients. [In reply to]

On 04/23/2012 10:23 AM, Ariel Weher wrote:
> Hi folks!
>
> I'm facing some problems with our brand new asr 1002's.
>
> We're having some issues with the clients being migrated from the old
> 7200-NPEG1 to the new BRAS with the following symptoms:
>
> The client (mostly old OSes like W2K and very old linux like debian potato)
> connects successfully, got an IP address and all of the PPP parameters,
> there is no traffic between the user and the net. Other users connects to
> the same BRAS without problems.


So basic troubleshooting -

Do the clients wind up with a 'default route' after connecting?
Can the clients ping a loopback or the pointtopoint address of the router?

If they can ping the asr-1k, then the questions would be where do their
packets do (routing table)? If they can't, then I'd bet you can look at
the client and see some obvious reason there.

$0.02

Mike-
_______________________________________________
cisco-nsp mailing list cisco-nsp [at] puck
https://puck.nether.net/mailman/listinfo/cisco-nsp
archive at http://puck.nether.net/pipermail/cisco-nsp/


avayner at cisco

Apr 23, 2012, 11:15 AM

Post #3 of 3 (956 views)
Permalink
Re: ASR-1K problem with old PPPoE clients. [In reply to]

Ariel,

Did you try to capture some sniffer traces of the PPPoE packets for
working and non-working clients?
This could give us some hint...

Arie

-----Original Message-----
From: cisco-nsp-bounces [at] puck
[mailto:cisco-nsp-bounces [at] puck] On Behalf Of Ariel Weher
Sent: Monday, April 23, 2012 10:23
To: cisco-nsp [at] puck
Subject: [c-nsp] ASR-1K problem with old PPPoE clients.

Hi folks!

I'm facing some problems with our brand new asr 1002's.

We're having some issues with the clients being migrated from the old
7200-NPEG1 to the new BRAS with the following symptoms:

The client (mostly old OSes like W2K and very old linux like debian
potato) connects successfully, got an IP address and all of the PPP
parameters, there is no traffic between the user and the net. Other
users connects to the same BRAS without problems.

This is a brief of our probes while using icmp to test the client
reachability:

BRAS -> Client [OK]
BRAS -> Client (Source interface other than Loopback) [OK] Client ->
BRAS (Any interface) [FAIL] Client -> any IP [FAIL] Any other host in
the network -> Client [FAIL]

The routes exists in the tables of all of our routers and

Any host of the net -> BRAS (Any local interface) [OK]

The configs are very basic, like

<asr-config>
ip name-server 8.8.8.8
ip name-server 8.8.4.4
!
bba-group pppoe PPPoE
virtual-template 1
sessions per-mac limit 1
sessions per-vlan limit 16000
sessions per-mac throttle 3 30 120
sessions auto cleanup
!
interface Loopback0
description Services
ip address 200.3.M.N 255.255.255.255
ip ospf 1 area 0
!
interface Loopback110
description OSPF Sum 190.X.Y.0/24
ip address 190.X.Y.1 255.255.255.255
ip ospf 1 area 400
!
! Multiple (50+) VLAN subif's like this
!
interface GigabitEthernet0/0/2.60
description PPPoEoVLAN 60
encapsulation dot1Q 60
pppoe enable group PPPoE
!
interface Virtual-Template1
ip unnumbered Loopback0
peer default ip address pool PPPoE-POOL ppp authentication pap !
router ospf 1
router-id 200.3.M.N
log-adjacency-changes detail
auto-cost reference-bandwidth 10000
area 400 range 190.X.Y.0 255.255.255.0
!
ip local pool PPPoE-POOL 190.X.Y.2 190.X.Y.254 </asr config>

And the show version:

Cisco IOS Software, IOS-XE Software (PPC_LINUX_IOSD-ADVENTERPRISEK9-M),
Version 15.1(2)S, RELEASE SOFTWARE (fc1) Technical Support:
http://www.cisco.com/techsupport Copyright (c) 1986-2011 by Cisco
Systems, Inc.
Compiled Thu 24-Mar-11 23:29 by mcpre

There are several clients connected to the router and a very little part
of them doesn't get the service.

sh pppoe sum
PTA : Locally terminated sessions
FWDED: Forwarded sessions
TRANS: All other sessions (in transient state)

TOTAL PTA FWDED TRANS
TOTAL 4221 4220 0 1
GigabitEthernet0/0/2 4221 4220 0 1

The TAC has no responses to give about this problem, and it's happening
in all of our new ASR. If you have any experience about an incident like
this, please drop me a few lines.

AFAIK there is no distinction about the L2 equipment serving the
customers.
If I pass the whole VLAN to our old BRAS all of the clients works fine
in the 7200 with the same config.

All of your suggestions are welcome.

Thanks for your time.

Regards.
_______________________________________________
cisco-nsp mailing list cisco-nsp [at] puck
https://puck.nether.net/mailman/listinfo/cisco-nsp
archive at http://puck.nether.net/pipermail/cisco-nsp/

_______________________________________________
cisco-nsp mailing list cisco-nsp [at] puck
https://puck.nether.net/mailman/listinfo/cisco-nsp
archive at http://puck.nether.net/pipermail/cisco-nsp/

Cisco nsp RSS feed   Index | Next | Previous | View Threaded
 
 


Interested in having your list archived? Contact Gossamer Threads
 
  Web Applications & Managed Hosting Powered by Gossamer Threads Inc.