Login | Register For Free | Help
Search for: (Advanced)

Mailing List Archive: Cisco: NSP

Cisco 7200 - IOS15.1 - Port-channel

 

 

Cisco nsp RSS feed   Index | Next | Previous | View Threaded


jason at pins

Apr 12, 2010, 12:30 PM

Post #1 of 7 (2544 views)
Permalink
Cisco 7200 - IOS15.1 - Port-channel

Greetings,

I just upgraded a Cisco 7206 NPE-400 to:
c7200-advipservicesk9-mz.151-1.XB.bin from the latest 12.4. I've got a
port channel and it removed the 'channel-group 1' line from the two
ethernet interfaces. When I try to add them back I get:

router(config-if)#channel-group 1
Error: This interface does not allow user-settable mtu.
Remove the mtu command from the port channel configuration
to be able to add this interfaceto the port channel

I don't have any mtu commands on any interfaces except the defaults,
which can't be removed. Here's the relevant config:

interface Port-channel1
description << TO GI9/5 10/5 >>
no ip address
no ip redirects
random-detect
!
interface Port-channel1.11
encapsulation dot1Q 11
ip address IP 255.255.255.0
no ip redirects
ip ospf authentication-key 7
ip ospf cost 1
ip ospf dead-interval minimal hello-multiplier 4
!
interface FastEthernet0/0
description << TO 9/5 >>
no ip address
no ip redirects
no ip unreachables
duplex full
random-detect
no cdp enable
!
interface FastEthernet2/0
description << TO 10/5 >>
no ip address
no ip redirects
no ip unreachables
duplex full
no cdp enable
!

Any tips/help would be greatly appreciated.

Thanks,
Jason
_______________________________________________
cisco-nsp mailing list cisco-nsp [at] puck
https://puck.nether.net/mailman/listinfo/cisco-nsp
archive at http://puck.nether.net/pipermail/cisco-nsp/


bg at billyguthrie

Apr 12, 2010, 5:41 PM

Post #2 of 7 (2489 views)
Permalink
Re: Cisco 7200 - IOS15.1 - Port-channel [In reply to]

Jason,

Very possible that you ran into a bug; I would try removing
channel-group from the FastE interfaces, remove the port-channel
interfaces, add the port-channels back in and then add the channel-group
back onto the FastE interfaces.

Good luck
Billy

Jason Berenson wrote:
> Greetings,
>
> I just upgraded a Cisco 7206 NPE-400 to:
> c7200-advipservicesk9-mz.151-1.XB.bin from the latest 12.4. I've got
> a port channel and it removed the 'channel-group 1' line from the two
> ethernet interfaces. When I try to add them back I get:
>
> router(config-if)#channel-group 1
> Error: This interface does not allow user-settable mtu.
> Remove the mtu command from the port channel configuration
> to be able to add this interfaceto the port channel
>
> I don't have any mtu commands on any interfaces except the defaults,
> which can't be removed. Here's the relevant config:
>
> interface Port-channel1
> description << TO GI9/5 10/5 >>
> no ip address
> no ip redirects
> random-detect
> !
> interface Port-channel1.11
> encapsulation dot1Q 11
> ip address IP 255.255.255.0
> no ip redirects
> ip ospf authentication-key 7
> ip ospf cost 1
> ip ospf dead-interval minimal hello-multiplier 4
> !
> interface FastEthernet0/0
> description << TO 9/5 >>
> no ip address
> no ip redirects
> no ip unreachables
> duplex full
> random-detect
> no cdp enable
> !
> interface FastEthernet2/0
> description << TO 10/5 >>
> no ip address
> no ip redirects
> no ip unreachables
> duplex full
> no cdp enable
> !
>
> Any tips/help would be greatly appreciated.
>
> Thanks,
> Jason
> _______________________________________________
> cisco-nsp mailing list cisco-nsp [at] puck
> https://puck.nether.net/mailman/listinfo/cisco-nsp
> archive at http://puck.nether.net/pipermail/cisco-nsp/
>

_______________________________________________
cisco-nsp mailing list cisco-nsp [at] puck
https://puck.nether.net/mailman/listinfo/cisco-nsp
archive at http://puck.nether.net/pipermail/cisco-nsp/


avayner at cisco

Apr 12, 2010, 11:12 PM

Post #3 of 7 (2516 views)
Permalink
Re: Cisco 7200 - IOS15.1 - Port-channel [In reply to]

Jason,

This looks like CSCte69575 "Etherchannel on HWIC-1FE not working."

I suggest you open a TAC case about it, to verify that this is the same
case (the above bug is for the 2900 platform, but my guess these are the
same).
Also, I am not sure right now in which release the fix is integrated.
TAC should be able to help you with that too.

Tnx
Arie



-----Original Message-----
From: cisco-nsp-bounces [at] puck
[mailto:cisco-nsp-bounces [at] puck] On Behalf Of Jason Berenson
Sent: Monday, April 12, 2010 22:31
To: cisco-nsp [at] puck
Subject: [c-nsp] Cisco 7200 - IOS15.1 - Port-channel

Greetings,

I just upgraded a Cisco 7206 NPE-400 to:
c7200-advipservicesk9-mz.151-1.XB.bin from the latest 12.4. I've got a
port channel and it removed the 'channel-group 1' line from the two
ethernet interfaces. When I try to add them back I get:

router(config-if)#channel-group 1
Error: This interface does not allow user-settable mtu.
Remove the mtu command from the port channel configuration
to be able to add this interfaceto the port channel

I don't have any mtu commands on any interfaces except the defaults,
which can't be removed. Here's the relevant config:

interface Port-channel1
description << TO GI9/5 10/5 >>
no ip address
no ip redirects
random-detect
!
interface Port-channel1.11
encapsulation dot1Q 11
ip address IP 255.255.255.0
no ip redirects
ip ospf authentication-key 7
ip ospf cost 1
ip ospf dead-interval minimal hello-multiplier 4
!
interface FastEthernet0/0
description << TO 9/5 >>
no ip address
no ip redirects
no ip unreachables
duplex full
random-detect
no cdp enable
!
interface FastEthernet2/0
description << TO 10/5 >>
no ip address
no ip redirects
no ip unreachables
duplex full
no cdp enable
!

Any tips/help would be greatly appreciated.

Thanks,
Jason
_______________________________________________
cisco-nsp mailing list cisco-nsp [at] puck
https://puck.nether.net/mailman/listinfo/cisco-nsp
archive at http://puck.nether.net/pipermail/cisco-nsp/

_______________________________________________
cisco-nsp mailing list cisco-nsp [at] puck
https://puck.nether.net/mailman/listinfo/cisco-nsp
archive at http://puck.nether.net/pipermail/cisco-nsp/


jason at pins

Apr 15, 2010, 12:04 PM

Post #4 of 7 (2453 views)
Permalink
Re: Cisco 7200 - IOS15.1 - Port-channel [In reply to]

Well, I downgraded to the latest 12.4 (c7200-is-mz.124-25c.bin). Same
symptoms. Any ideas? I tried removing the port-channel and re-adding
too, no luck.

-Jason

On 4/12/2010 3:30 PM, Jason Berenson wrote:
> Greetings,
>
> I just upgraded a Cisco 7206 NPE-400 to:
> c7200-advipservicesk9-mz.151-1.XB.bin from the latest 12.4. I've got
> a port channel and it removed the 'channel-group 1' line from the two
> ethernet interfaces. When I try to add them back I get:
>
> router(config-if)#channel-group 1
> Error: This interface does not allow user-settable mtu.
> Remove the mtu command from the port channel configuration
> to be able to add this interfaceto the port channel
>
> I don't have any mtu commands on any interfaces except the defaults,
> which can't be removed. Here's the relevant config:
>
> interface Port-channel1
> description << TO GI9/5 10/5 >>
> no ip address
> no ip redirects
> random-detect
> !
> interface Port-channel1.11
> encapsulation dot1Q 11
> ip address IP 255.255.255.0
> no ip redirects
> ip ospf authentication-key 7
> ip ospf cost 1
> ip ospf dead-interval minimal hello-multiplier 4
> !
> interface FastEthernet0/0
> description << TO 9/5 >>
> no ip address
> no ip redirects
> no ip unreachables
> duplex full
> random-detect
> no cdp enable
> !
> interface FastEthernet2/0
> description << TO 10/5 >>
> no ip address
> no ip redirects
> no ip unreachables
> duplex full
> no cdp enable
> !
>
> Any tips/help would be greatly appreciated.
>
> Thanks,
> Jason
> _______________________________________________
> cisco-nsp mailing list cisco-nsp [at] puck
> https://puck.nether.net/mailman/listinfo/cisco-nsp
> archive at http://puck.nether.net/pipermail/cisco-nsp/
_______________________________________________
cisco-nsp mailing list cisco-nsp [at] puck
https://puck.nether.net/mailman/listinfo/cisco-nsp
archive at http://puck.nether.net/pipermail/cisco-nsp/


bg at billyguthrie

Apr 15, 2010, 5:06 PM

Post #5 of 7 (2440 views)
Permalink
Re: Cisco 7200 - IOS15.1 - Port-channel [In reply to]

Jason,

Please provide a
show version
show inventory
show controllers fast0/0
show controllers fast2/0

Thanks
Billy

Jason Berenson wrote:
> Well, I downgraded to the latest 12.4 (c7200-is-mz.124-25c.bin). Same
> symptoms. Any ideas? I tried removing the port-channel and re-adding
> too, no luck.
>
> -Jason
>
> On 4/12/2010 3:30 PM, Jason Berenson wrote:
>> Greetings,
>>
>> I just upgraded a Cisco 7206 NPE-400 to:
>> c7200-advipservicesk9-mz.151-1.XB.bin from the latest 12.4. I've got
>> a port channel and it removed the 'channel-group 1' line from the two
>> ethernet interfaces. When I try to add them back I get:
>>
>> router(config-if)#channel-group 1
>> Error: This interface does not allow user-settable mtu.
>> Remove the mtu command from the port channel configuration
>> to be able to add this interfaceto the port channel
>>
>> I don't have any mtu commands on any interfaces except the defaults,
>> which can't be removed. Here's the relevant config:
>>
>> interface Port-channel1
>> description << TO GI9/5 10/5 >>
>> no ip address
>> no ip redirects
>> random-detect
>> !
>> interface Port-channel1.11
>> encapsulation dot1Q 11
>> ip address IP 255.255.255.0
>> no ip redirects
>> ip ospf authentication-key 7
>> ip ospf cost 1
>> ip ospf dead-interval minimal hello-multiplier 4
>> !
>> interface FastEthernet0/0
>> description << TO 9/5 >>
>> no ip address
>> no ip redirects
>> no ip unreachables
>> duplex full
>> random-detect
>> no cdp enable
>> !
>> interface FastEthernet2/0
>> description << TO 10/5 >>
>> no ip address
>> no ip redirects
>> no ip unreachables
>> duplex full
>> no cdp enable
>> !
>>
>> Any tips/help would be greatly appreciated.
>>
>> Thanks,
>> Jason
>> _______________________________________________
>> cisco-nsp mailing list cisco-nsp [at] puck
>> https://puck.nether.net/mailman/listinfo/cisco-nsp
>> archive at http://puck.nether.net/pipermail/cisco-nsp/
> _______________________________________________
> cisco-nsp mailing list cisco-nsp [at] puck
> https://puck.nether.net/mailman/listinfo/cisco-nsp
> archive at http://puck.nether.net/pipermail/cisco-nsp/
>

_______________________________________________
cisco-nsp mailing list cisco-nsp [at] puck
https://puck.nether.net/mailman/listinfo/cisco-nsp
archive at http://puck.nether.net/pipermail/cisco-nsp/


bg at billyguthrie

Apr 15, 2010, 5:53 PM

Post #6 of 7 (2497 views)
Permalink
Re: Cisco 7200 - IOS15.1 - Port-channel [In reply to]

Jason,

I found this:

CSCsc62963

Symptoms: The interface MTU is not user configurable. When you attempt
to configure the interface level command mtu command, the following
message is printed:

% Interface {Interface Name} does not support user settable mtu.

Conditions: The symptom is observed with a 2-port FE on a Cisco 7200
series router.

Workaround: There is no workaround.

Says it was fixed in Version 12.4(25c), also applies to the 2-port FE;
however, it states to remove the mtu setting on the port-cahnnel could
still very well be related to a variant of the bug. I was about to
configure the FastE interface using Version 12.2(33)SRD4, so as
suggested, I would open a case with TAC as it clearly appears to be a bug.

Good Luck
Billy

Jason Berenson wrote:
> Well, I downgraded to the latest 12.4 (c7200-is-mz.124-25c.bin). Same
> symptoms. Any ideas? I tried removing the port-channel and re-adding
> too, no luck.
>
> -Jason
>
> On 4/12/2010 3:30 PM, Jason Berenson wrote:
>> Greetings,
>>
>> I just upgraded a Cisco 7206 NPE-400 to:
>> c7200-advipservicesk9-mz.151-1.XB.bin from the latest 12.4. I've got
>> a port channel and it removed the 'channel-group 1' line from the two
>> ethernet interfaces. When I try to add them back I get:
>>
>> router(config-if)#channel-group 1
>> Error: This interface does not allow user-settable mtu.
>> Remove the mtu command from the port channel configuration
>> to be able to add this interfaceto the port channel
>>
>> I don't have any mtu commands on any interfaces except the defaults,
>> which can't be removed. Here's the relevant config:
>>
>> interface Port-channel1
>> description << TO GI9/5 10/5 >>
>> no ip address
>> no ip redirects
>> random-detect
>> !
>> interface Port-channel1.11
>> encapsulation dot1Q 11
>> ip address IP 255.255.255.0
>> no ip redirects
>> ip ospf authentication-key 7
>> ip ospf cost 1
>> ip ospf dead-interval minimal hello-multiplier 4
>> !
>> interface FastEthernet0/0
>> description << TO 9/5 >>
>> no ip address
>> no ip redirects
>> no ip unreachables
>> duplex full
>> random-detect
>> no cdp enable
>> !
>> interface FastEthernet2/0
>> description << TO 10/5 >>
>> no ip address
>> no ip redirects
>> no ip unreachables
>> duplex full
>> no cdp enable
>> !
>>
>> Any tips/help would be greatly appreciated.
>>
>> Thanks,
>> Jason
>> _______________________________________________
>> cisco-nsp mailing list cisco-nsp [at] puck
>> https://puck.nether.net/mailman/listinfo/cisco-nsp
>> archive at http://puck.nether.net/pipermail/cisco-nsp/
> _______________________________________________
> cisco-nsp mailing list cisco-nsp [at] puck
> https://puck.nether.net/mailman/listinfo/cisco-nsp
> archive at http://puck.nether.net/pipermail/cisco-nsp/
>

_______________________________________________
cisco-nsp mailing list cisco-nsp [at] puck
https://puck.nether.net/mailman/listinfo/cisco-nsp
archive at http://puck.nether.net/pipermail/cisco-nsp/


oboehmer at cisco

Apr 16, 2010, 12:41 AM

Post #7 of 7 (2474 views)
Permalink
Re: Cisco 7200 - IOS15.1 - Port-channel [In reply to]

The fix is not in 12.4(25c), will be in 25d. As indicated off-list,
please use 15.0(1)M2 to get the fix, or downgrade to a release which
doesn't have CSCsc62963 integrated, which caused the regression (for
example 12.4(25a) or earlier)..

oli

> Well, I downgraded to the latest 12.4 (c7200-is-mz.124-25c.bin). Same
> symptoms. Any ideas? I tried removing the port-channel and re-adding
> too, no luck.
>
> -Jason
>
> On 4/12/2010 3:30 PM, Jason Berenson wrote:
> > Greetings,
> >
> > I just upgraded a Cisco 7206 NPE-400 to:
> > c7200-advipservicesk9-mz.151-1.XB.bin from the latest 12.4. I've
got
> > a port channel and it removed the 'channel-group 1' line from the
two
> > ethernet interfaces. When I try to add them back I get:
> >
> > router(config-if)#channel-group 1
> > Error: This interface does not allow user-settable mtu.
> > Remove the mtu command from the port channel configuration
> > to be able to add this interfaceto the port channel
> >
> > I don't have any mtu commands on any interfaces except the defaults,
> > which can't be removed. Here's the relevant config:
> >
> > interface Port-channel1
> > description << TO GI9/5 10/5 >>
> > no ip address
> > no ip redirects
> > random-detect
> > !
> > interface Port-channel1.11
> > encapsulation dot1Q 11
> > ip address IP 255.255.255.0
> > no ip redirects
> > ip ospf authentication-key 7
> > ip ospf cost 1
> > ip ospf dead-interval minimal hello-multiplier 4
> > !
> > interface FastEthernet0/0
> > description << TO 9/5 >>
> > no ip address
> > no ip redirects
> > no ip unreachables
> > duplex full
> > random-detect
> > no cdp enable
> > !
> > interface FastEthernet2/0
> > description << TO 10/5 >>
> > no ip address
> > no ip redirects
> > no ip unreachables
> > duplex full
> > no cdp enable
> > !
> >
> > Any tips/help would be greatly appreciated.
> >
> > Thanks,
> > Jason
> > _______________________________________________
> > cisco-nsp mailing list cisco-nsp [at] puck
> > https://puck.nether.net/mailman/listinfo/cisco-nsp
> > archive at http://puck.nether.net/pipermail/cisco-nsp/
> _______________________________________________
> cisco-nsp mailing list cisco-nsp [at] puck
> https://puck.nether.net/mailman/listinfo/cisco-nsp
> archive at http://puck.nether.net/pipermail/cisco-nsp/

_______________________________________________
cisco-nsp mailing list cisco-nsp [at] puck
https://puck.nether.net/mailman/listinfo/cisco-nsp
archive at http://puck.nether.net/pipermail/cisco-nsp/

Cisco nsp RSS feed   Index | Next | Previous | View Threaded
 
 


Interested in having your list archived? Contact Gossamer Threads
 
  Web Applications & Managed Hosting Powered by Gossamer Threads Inc.