Login | Register For Free | Help
Search for: (Advanced)

Mailing List Archive: Cisco: NSP

Data VLAN/Voice VLAN

 

 

Cisco nsp RSS feed   Index | Next | Previous | View Threaded


yurixewx at yahoo

Aug 28, 2009, 3:20 PM

Post #1 of 11 (2526 views)
Permalink
Data VLAN/Voice VLAN

According to cisco documentation, when you specify a voice-vlan for a switchport, the data is then Untagged; Native VLAN.

Example configuration.

interface FastEthernet0/4
description phone
switchport access vlan 77
switchport trunk native vlan 55
switchport mode access
switchport voice vlan 66



In this configuration, data is placed on vlan 55? From what I've read on other forums and such is that the data would be on the configured access vlan ( 77 ). Unfortunately I do not have an iphone to test this. Could anyone give me some clarity?






_______________________________________________
cisco-nsp mailing list cisco-nsp [at] puck
https://puck.nether.net/mailman/listinfo/cisco-nsp
archive at http://puck.nether.net/pipermail/cisco-nsp/


peter at rathlev

Aug 28, 2009, 3:43 PM

Post #2 of 11 (2465 views)
Permalink
Re: Data VLAN/Voice VLAN [In reply to]

On Fri, 2009-08-28 at 15:20 -0700, Yuri Bank wrote:
> interface FastEthernet0/4
> description phone
> switchport access vlan 77
> switchport trunk native vlan 55
> switchport mode access
> switchport voice vlan 66
>
> In this configuration, data is placed on vlan 55? From what I've read
> on other forums and such is that the data would be on the configured
> access vlan ( 77 ). Unfortunately I do not have an iphone to test
> this. Could anyone give me some clarity?

Untagged traffic on the port would be VLAN 77, since this is what you
configured at access VLAN and since the port is in forced access mode.

A compatible device (i.e. one the presents itself as a phone via CDP)
would activate the voice VLAN and thus allow tagged incoming traffic on
VLAN 66. This requires the switch (and port) to have CDP enabled by the
way.

The trunk configuration is ignored when you issue "switchport mode
access".

If you only need a stand-alone phone you can just use a simple access
port in the voice VLAN.

Regards,
Peter


_______________________________________________
cisco-nsp mailing list cisco-nsp [at] puck
https://puck.nether.net/mailman/listinfo/cisco-nsp
archive at http://puck.nether.net/pipermail/cisco-nsp/


BBlackford at nwresd

Aug 28, 2009, 4:52 PM

Post #3 of 11 (2463 views)
Permalink
Re: Data VLAN/Voice VLAN [In reply to]

If you are using 3560's, this has been my experience as well. If you are unfortunate enough to be using 3550XL's, then the whole game is different.

The 3550XL way:

interface FastEthernet0/5
switchport trunk encapsulation dot1q
switchport trunk native vlan 68
switchport mode trunk
switchport voice vlan 66
switchport priority extend cos 0
spanning-tree portfast

The data vlan has to be indicated as native.

Again, this has been my experience.

-b



-----Original Message-----
From: cisco-nsp-bounces [at] puck [mailto:cisco-nsp-bounces [at] puck] On Behalf Of Peter Rathlev
Sent: Friday, August 28, 2009 3:44 PM
To: Yuri Bank
Cc: cisco-nsp [at] puck
Subject: Re: [c-nsp] Data VLAN/Voice VLAN

On Fri, 2009-08-28 at 15:20 -0700, Yuri Bank wrote:
> interface FastEthernet0/4
> description phone
> switchport access vlan 77
> switchport trunk native vlan 55
> switchport mode access
> switchport voice vlan 66
>
> In this configuration, data is placed on vlan 55? From what I've read
> on other forums and such is that the data would be on the configured
> access vlan ( 77 ). Unfortunately I do not have an iphone to test
> this. Could anyone give me some clarity?

Untagged traffic on the port would be VLAN 77, since this is what you
configured at access VLAN and since the port is in forced access mode.

A compatible device (i.e. one the presents itself as a phone via CDP)
would activate the voice VLAN and thus allow tagged incoming traffic on
VLAN 66. This requires the switch (and port) to have CDP enabled by the
way.

The trunk configuration is ignored when you issue "switchport mode
access".

If you only need a stand-alone phone you can just use a simple access
port in the voice VLAN.

Regards,
Peter


_______________________________________________
cisco-nsp mailing list cisco-nsp [at] puck
https://puck.nether.net/mailman/listinfo/cisco-nsp
archive at http://puck.nether.net/pipermail/cisco-nsp/
_______________________________________________
cisco-nsp mailing list cisco-nsp [at] puck
https://puck.nether.net/mailman/listinfo/cisco-nsp
archive at http://puck.nether.net/pipermail/cisco-nsp/


cluestore at gmail

Aug 30, 2009, 12:45 AM

Post #4 of 11 (2441 views)
Permalink
Re: Data VLAN/Voice VLAN [In reply to]

What platform/IOS are you running??

I think the older 3500xl PoE switch had to be in trunk mode to accomplish
the dot1(p)(q) header info so trust the EF marking of the packet
would work due to CDP improvements and working without actually having a it
in "trunk mode". Think newer platforms and IOS, CDP does the magic of the
headers of the aux vlan (which is the voice vlan) if im not mitaken. And u
can just use voice vlan and access mode and it works.

So no need to trunk on newer gear. But Pete's correct, u have the switchport
"mode" in access. And u might have to trunk depending on ur setup. Also
having it tagging "native" is useless in access mode.

HTH,
Clue

On Fri, Aug 28, 2009 at 6:52 PM, Bill Blackford <BBlackford [at] nwresd
> wrote:

> If you are using 3560's, this has been my experience as well. If you are
> unfortunate enough to be using 3550XL's, then the whole game is different.
>
> The 3550XL way:
>
> interface FastEthernet0/5
> switchport trunk encapsulation dot1q
> switchport trunk native vlan 68
> switchport mode trunk
> switchport voice vlan 66
> switchport priority extend cos 0
> spanning-tree portfast
>
> The data vlan has to be indicated as native.
>
> Again, this has been my experience.
>
> -b
>
>
>
> -----Original Message-----
> From: cisco-nsp-bounces [at] puck [mailto:
> cisco-nsp-bounces [at] puck] On Behalf Of Peter Rathlev
> Sent: Friday, August 28, 2009 3:44 PM
> To: Yuri Bank
> Cc: cisco-nsp [at] puck
> Subject: Re: [c-nsp] Data VLAN/Voice VLAN
>
> On Fri, 2009-08-28 at 15:20 -0700, Yuri Bank wrote:
> > interface FastEthernet0/4
> > description phone
> > switchport access vlan 77
> > switchport trunk native vlan 55
> > switchport mode access
> > switchport voice vlan 66
> >
> > In this configuration, data is placed on vlan 55? From what I've read
> > on other forums and such is that the data would be on the configured
> > access vlan ( 77 ). Unfortunately I do not have an iphone to test
> > this. Could anyone give me some clarity?
>
> Untagged traffic on the port would be VLAN 77, since this is what you
> configured at access VLAN and since the port is in forced access mode.
>
> A compatible device (i.e. one the presents itself as a phone via CDP)
> would activate the voice VLAN and thus allow tagged incoming traffic on
> VLAN 66. This requires the switch (and port) to have CDP enabled by the
> way.
>
> The trunk configuration is ignored when you issue "switchport mode
> access".
>
> If you only need a stand-alone phone you can just use a simple access
> port in the voice VLAN.
>
> Regards,
> Peter
>
>
> _______________________________________________
> cisco-nsp mailing list cisco-nsp [at] puck
> https://puck.nether.net/mailman/listinfo/cisco-nsp
> archive at http://puck.nether.net/pipermail/cisco-nsp/
> _______________________________________________
> cisco-nsp mailing list cisco-nsp [at] puck
> https://puck.nether.net/mailman/listinfo/cisco-nsp
> archive at http://puck.nether.net/pipermail/cisco-nsp/
>
_______________________________________________
cisco-nsp mailing list cisco-nsp [at] puck
https://puck.nether.net/mailman/listinfo/cisco-nsp
archive at http://puck.nether.net/pipermail/cisco-nsp/


geoff at pendery

Aug 31, 2009, 6:24 AM

Post #5 of 11 (2422 views)
Permalink
Re: Data VLAN/Voice VLAN [In reply to]

"A compatible device (i.e. one the presents itself as a phone via CDP)
would activate the voice VLAN and thus allow tagged incoming traffic
on VLAN 66. This requires the switch (and port) to have CDP enabled by
the way."


Can also be done with LLDP, should you have non-Cisco IP phones. I
can vouch for 4500's and Avaya IP phones speaking LLDP to each other.


-Geoff


On Fri, Aug 28, 2009 at 5:43 PM, Peter Rathlev<peter [at] rathlev> wrote:
> On Fri, 2009-08-28 at 15:20 -0700, Yuri Bank wrote:
>> interface FastEthernet0/4
>>  description phone
>>  switchport access vlan 77
>>  switchport trunk native vlan 55
>>  switchport mode access
>>  switchport voice vlan 66
>>
>> In this configuration, data is placed on vlan 55? From what I've read
>> on other forums and such is that the data would be on the configured
>> access vlan ( 77 ). Unfortunately I do not have an iphone to test
>> this. Could anyone give me some clarity?
>
> Untagged traffic on the port would be VLAN 77, since this is what you
> configured at access VLAN and since the port is in forced access mode.
>
> A compatible device (i.e. one the presents itself as a phone via CDP)
> would activate the voice VLAN and thus allow tagged incoming traffic on
> VLAN 66. This requires the switch (and port) to have CDP enabled by the
> way.
>
> The trunk configuration is ignored when you issue "switchport mode
> access".
>
> If you only need a stand-alone phone you can just use a simple access
> port in the voice VLAN.
>
> Regards,
> Peter
>
>
> _______________________________________________
> cisco-nsp mailing list  cisco-nsp [at] puck
> https://puck.nether.net/mailman/listinfo/cisco-nsp
> archive at http://puck.nether.net/pipermail/cisco-nsp/
>
_______________________________________________
cisco-nsp mailing list cisco-nsp [at] puck
https://puck.nether.net/mailman/listinfo/cisco-nsp
archive at http://puck.nether.net/pipermail/cisco-nsp/


BBlackford at nwresd

Aug 31, 2009, 6:43 AM

Post #6 of 11 (2439 views)
Permalink
Re: Data VLAN/Voice VLAN [In reply to]

I agree. LLDP is fairly slick. We're currently doing it with a non-Cisco switch and Cisco phones in some of our smaller sites.

-b

-----Original Message-----
From: cisco-nsp-bounces [at] puck [mailto:cisco-nsp-bounces [at] puck] On Behalf Of Geoffrey Pendery
Sent: Monday, August 31, 2009 6:25 AM
To: Peter Rathlev
Cc: cisco-nsp [at] puck
Subject: Re: [c-nsp] Data VLAN/Voice VLAN

"A compatible device (i.e. one the presents itself as a phone via CDP)
would activate the voice VLAN and thus allow tagged incoming traffic
on VLAN 66. This requires the switch (and port) to have CDP enabled by
the way."


Can also be done with LLDP, should you have non-Cisco IP phones. I
can vouch for 4500's and Avaya IP phones speaking LLDP to each other.


-Geoff


On Fri, Aug 28, 2009 at 5:43 PM, Peter Rathlev<peter [at] rathlev> wrote:
> On Fri, 2009-08-28 at 15:20 -0700, Yuri Bank wrote:
>> interface FastEthernet0/4
>>  description phone
>>  switchport access vlan 77
>>  switchport trunk native vlan 55
>>  switchport mode access
>>  switchport voice vlan 66
>>
>> In this configuration, data is placed on vlan 55? From what I've read
>> on other forums and such is that the data would be on the configured
>> access vlan ( 77 ). Unfortunately I do not have an iphone to test
>> this. Could anyone give me some clarity?
>
> Untagged traffic on the port would be VLAN 77, since this is what you
> configured at access VLAN and since the port is in forced access mode.
>
> A compatible device (i.e. one the presents itself as a phone via CDP)
> would activate the voice VLAN and thus allow tagged incoming traffic on
> VLAN 66. This requires the switch (and port) to have CDP enabled by the
> way.
>
> The trunk configuration is ignored when you issue "switchport mode
> access".
>
> If you only need a stand-alone phone you can just use a simple access
> port in the voice VLAN.
>
> Regards,
> Peter
>
>
> _______________________________________________
> cisco-nsp mailing list  cisco-nsp [at] puck
> https://puck.nether.net/mailman/listinfo/cisco-nsp
> archive at http://puck.nether.net/pipermail/cisco-nsp/
>
_______________________________________________
cisco-nsp mailing list cisco-nsp [at] puck
https://puck.nether.net/mailman/listinfo/cisco-nsp
archive at http://puck.nether.net/pipermail/cisco-nsp/
_______________________________________________
cisco-nsp mailing list cisco-nsp [at] puck
https://puck.nether.net/mailman/listinfo/cisco-nsp
archive at http://puck.nether.net/pipermail/cisco-nsp/


akg1330 at gmail

Aug 31, 2009, 6:58 AM

Post #7 of 11 (2432 views)
Permalink
Re: Data VLAN/Voice VLAN [In reply to]

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Would you mind sharing your IOS config, DHCP options, phone version &
settings file?

I've had varying success with Avaya and Cisco LLDP.

Then again, I'm using SIP loads on the phones.

Thanks.



Geoffrey Pendery wrote:
> "A compatible device (i.e. one the presents itself as a phone via CDP)
> would activate the voice VLAN and thus allow tagged incoming traffic
> on VLAN 66. This requires the switch (and port) to have CDP enabled by
> the way."
>
>
> Can also be done with LLDP, should you have non-Cisco IP phones. I
> can vouch for 4500's and Avaya IP phones speaking LLDP to each other.
>
>
> -Geoff
>
>
> On Fri, Aug 28, 2009 at 5:43 PM, Peter Rathlev<peter [at] rathlev> wrote:
>> On Fri, 2009-08-28 at 15:20 -0700, Yuri Bank wrote:
>>> interface FastEthernet0/4
>>> description phone
>>> switchport access vlan 77
>>> switchport trunk native vlan 55
>>> switchport mode access
>>> switchport voice vlan 66
>>>
>>> In this configuration, data is placed on vlan 55? From what I've read
>>> on other forums and such is that the data would be on the configured
>>> access vlan ( 77 ). Unfortunately I do not have an iphone to test
>>> this. Could anyone give me some clarity?
>> Untagged traffic on the port would be VLAN 77, since this is what you
>> configured at access VLAN and since the port is in forced access mode.
>>
>> A compatible device (i.e. one the presents itself as a phone via CDP)
>> would activate the voice VLAN and thus allow tagged incoming traffic on
>> VLAN 66. This requires the switch (and port) to have CDP enabled by the
>> way.
>>
>> The trunk configuration is ignored when you issue "switchport mode
>> access".
>>
>> If you only need a stand-alone phone you can just use a simple access
>> port in the voice VLAN.
>>
>> Regards,
>> Peter
>>
>>
>> _______________________________________________
>> cisco-nsp mailing list cisco-nsp [at] puck
>> https://puck.nether.net/mailman/listinfo/cisco-nsp
>> archive at http://puck.nether.net/pipermail/cisco-nsp/
>>
> _______________________________________________
> cisco-nsp mailing list cisco-nsp [at] puck
> https://puck.nether.net/mailman/listinfo/cisco-nsp
> archive at http://puck.nether.net/pipermail/cisco-nsp/

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.8 (MingW32)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

iEYEARECAAYFAkqb1vcACgkQQr/gMVyFYyTa/gCcDNV9xBQF5p+2pR1L5lgKf2Tp
54kAniLjnhkcI2We/Gd+Szlil9oFBnL1
=+bFG
-----END PGP SIGNATURE-----
_______________________________________________
cisco-nsp mailing list cisco-nsp [at] puck
https://puck.nether.net/mailman/listinfo/cisco-nsp
archive at http://puck.nether.net/pipermail/cisco-nsp/


geoff at pendery

Aug 31, 2009, 8:30 AM

Post #8 of 11 (2429 views)
Permalink
Re: Data VLAN/Voice VLAN [In reply to]

The TAC engineer I asked for configuration help found this link for me
(I feel dumb being simply out-Googled, but appreciative that he went
outside Cisco-only docs and actually found me good interop info)

http://www.avaya.de/emea/de/resource/assets/applicationnotes/CSCO_LLDP-MED.pdf

On the access ports, we have:
switchport
switchport host
switchport access vlan 100
switchport voice vlan 400

And globally all I had to turn on was "lldp run"

We do connect workstations through the phone's built-in switch, and we
do use the separate data and voice VLANs. Operationally, we're
serving the DHCP options to the phones (a big string of variables in
option 176) but in the lab I verified the phone would receive and use
the voice and data VLANs separate via LLDP parameters, without help
from DHCP.

The only thing I noticed missing was the precise power info. AF power
determines that the phone is class 2, so it allocates 7.9 Watts from
the PS, but if CDP was there (or the Power TLVs in LLDP were open
standard, instead of Avaya Propreitary) then it would get the more
precise consumption (say 6.2 Watt) and be able to allocate more phones
out of the same PS.

Other than that, seems to work like a charm. We get lots of good info
from the phones via LLDP.


-Geoff


On Mon, Aug 31, 2009 at 8:58 AM, Andrew Gallo<akg1330 [at] gmail> wrote:
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
>
> Would you mind sharing your IOS config, DHCP options, phone version &
> settings file?
>
> I've had varying success with Avaya and Cisco LLDP.
>
> Then again, I'm using SIP loads on the phones.
>
> Thanks.
>
>
>
> Geoffrey Pendery wrote:
>> "A compatible device (i.e. one the presents itself as a phone via CDP)
>> would activate the voice VLAN and thus allow tagged incoming traffic
>> on VLAN 66. This requires the switch (and port) to have CDP enabled by
>> the way."
>>
>>
>> Can also be done with LLDP, should you have non-Cisco IP phones.  I
>> can vouch for 4500's and Avaya IP phones speaking LLDP to each other.
>>
>>
>> -Geoff
>>
>>
>> On Fri, Aug 28, 2009 at 5:43 PM, Peter Rathlev<peter [at] rathlev> wrote:
>>> On Fri, 2009-08-28 at 15:20 -0700, Yuri Bank wrote:
>>>> interface FastEthernet0/4
>>>>  description phone
>>>>  switchport access vlan 77
>>>>  switchport trunk native vlan 55
>>>>  switchport mode access
>>>>  switchport voice vlan 66
>>>>
>>>> In this configuration, data is placed on vlan 55? From what I've read
>>>> on other forums and such is that the data would be on the configured
>>>> access vlan ( 77 ). Unfortunately I do not have an iphone to test
>>>> this. Could anyone give me some clarity?
>>> Untagged traffic on the port would be VLAN 77, since this is what you
>>> configured at access VLAN and since the port is in forced access mode.
>>>
>>> A compatible device (i.e. one the presents itself as a phone via CDP)
>>> would activate the voice VLAN and thus allow tagged incoming traffic on
>>> VLAN 66. This requires the switch (and port) to have CDP enabled by the
>>> way.
>>>
>>> The trunk configuration is ignored when you issue "switchport mode
>>> access".
>>>
>>> If you only need a stand-alone phone you can just use a simple access
>>> port in the voice VLAN.
>>>
>>> Regards,
>>> Peter
>>>
>>>
>>> _______________________________________________
>>> cisco-nsp mailing list  cisco-nsp [at] puck
>>> https://puck.nether.net/mailman/listinfo/cisco-nsp
>>> archive at http://puck.nether.net/pipermail/cisco-nsp/
>>>
>> _______________________________________________
>> cisco-nsp mailing list  cisco-nsp [at] puck
>> https://puck.nether.net/mailman/listinfo/cisco-nsp
>> archive at http://puck.nether.net/pipermail/cisco-nsp/
>
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.4.8 (MingW32)
> Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/
>
> iEYEARECAAYFAkqb1vcACgkQQr/gMVyFYyTa/gCcDNV9xBQF5p+2pR1L5lgKf2Tp
> 54kAniLjnhkcI2We/Gd+Szlil9oFBnL1
> =+bFG
> -----END PGP SIGNATURE-----
>
_______________________________________________
cisco-nsp mailing list cisco-nsp [at] puck
https://puck.nether.net/mailman/listinfo/cisco-nsp
archive at http://puck.nether.net/pipermail/cisco-nsp/


akg1330 at gmail

Aug 31, 2009, 10:13 AM

Post #9 of 11 (2450 views)
Permalink
Re: Data VLAN/Voice VLAN [In reply to]

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Thanks Geoffrey!

Geoffrey Pendery wrote:
> The TAC engineer I asked for configuration help found this link for me
> (I feel dumb being simply out-Googled, but appreciative that he went
> outside Cisco-only docs and actually found me good interop info)
>
> http://www.avaya.de/emea/de/resource/assets/applicationnotes/CSCO_LLDP-MED.pdf
>
> On the access ports, we have:
> switchport
> switchport host
> switchport access vlan 100
> switchport voice vlan 400
>
> And globally all I had to turn on was "lldp run"
>
> We do connect workstations through the phone's built-in switch, and we
> do use the separate data and voice VLANs. Operationally, we're
> serving the DHCP options to the phones (a big string of variables in
> option 176) but in the lab I verified the phone would receive and use
> the voice and data VLANs separate via LLDP parameters, without help
> from DHCP.
>
> The only thing I noticed missing was the precise power info. AF power
> determines that the phone is class 2, so it allocates 7.9 Watts from
> the PS, but if CDP was there (or the Power TLVs in LLDP were open
> standard, instead of Avaya Propreitary) then it would get the more
> precise consumption (say 6.2 Watt) and be able to allocate more phones
> out of the same PS.
>
> Other than that, seems to work like a charm. We get lots of good info
> from the phones via LLDP.
>
>
> -Geoff
>
>
> On Mon, Aug 31, 2009 at 8:58 AM, Andrew Gallo<akg1330 [at] gmail> wrote:
> Would you mind sharing your IOS config, DHCP options, phone version &
> settings file?
>
> I've had varying success with Avaya and Cisco LLDP.
>
> Then again, I'm using SIP loads on the phones.
>
> Thanks.
>
>
>
> Geoffrey Pendery wrote:
>>>> "A compatible device (i.e. one the presents itself as a phone via CDP)
>>>> would activate the voice VLAN and thus allow tagged incoming traffic
>>>> on VLAN 66. This requires the switch (and port) to have CDP enabled by
>>>> the way."
>>>>
>>>>
>>>> Can also be done with LLDP, should you have non-Cisco IP phones. I
>>>> can vouch for 4500's and Avaya IP phones speaking LLDP to each other.
>>>>
>>>>
>>>> -Geoff
>>>>
>>>>
>>>> On Fri, Aug 28, 2009 at 5:43 PM, Peter Rathlev<peter [at] rathlev> wrote:
>>>>> On Fri, 2009-08-28 at 15:20 -0700, Yuri Bank wrote:
>>>>>> interface FastEthernet0/4
>>>>>> description phone
>>>>>> switchport access vlan 77
>>>>>> switchport trunk native vlan 55
>>>>>> switchport mode access
>>>>>> switchport voice vlan 66
>>>>>>
>>>>>> In this configuration, data is placed on vlan 55? From what I've read
>>>>>> on other forums and such is that the data would be on the configured
>>>>>> access vlan ( 77 ). Unfortunately I do not have an iphone to test
>>>>>> this. Could anyone give me some clarity?
>>>>> Untagged traffic on the port would be VLAN 77, since this is what you
>>>>> configured at access VLAN and since the port is in forced access mode.
>>>>>
>>>>> A compatible device (i.e. one the presents itself as a phone via CDP)
>>>>> would activate the voice VLAN and thus allow tagged incoming traffic on
>>>>> VLAN 66. This requires the switch (and port) to have CDP enabled by the
>>>>> way.
>>>>>
>>>>> The trunk configuration is ignored when you issue "switchport mode
>>>>> access".
>>>>>
>>>>> If you only need a stand-alone phone you can just use a simple access
>>>>> port in the voice VLAN.
>>>>>
>>>>> Regards,
>>>>> Peter
>>>>>
>>>>>
>>>>> _______________________________________________
>>>>> cisco-nsp mailing list cisco-nsp [at] puck
>>>>> https://puck.nether.net/mailman/listinfo/cisco-nsp
>>>>> archive at http://puck.nether.net/pipermail/cisco-nsp/
>>>>>
>>>> _______________________________________________
>>>> cisco-nsp mailing list cisco-nsp [at] puck
>>>> https://puck.nether.net/mailman/listinfo/cisco-nsp
>>>> archive at http://puck.nether.net/pipermail/cisco-nsp/
>>

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.8 (MingW32)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

iEYEARECAAYFAkqcBKUACgkQQr/gMVyFYyTJ2ACcD41gE1qBl8+i5XmydDiFgXas
cB0AmgN265lz1L1sjO+jRABVN/BqqvZF
=bSe4
-----END PGP SIGNATURE-----
_______________________________________________
cisco-nsp mailing list cisco-nsp [at] puck
https://puck.nether.net/mailman/listinfo/cisco-nsp
archive at http://puck.nether.net/pipermail/cisco-nsp/


A.L.M.Buxey at lboro

Aug 31, 2009, 1:51 PM

Post #10 of 11 (2421 views)
Permalink
Re: Data VLAN/Voice VLAN [In reply to]

Hi,
> I agree. LLDP is fairly slick. We're currently doing it with a non-Cisco switch and Cisco phones in some of our smaller sites.

..and i noted that LLDP is slowly leaking out as a feature on cisco switches -
recent IOS for 3560 and 2960 switches can speak it... service needs to be turned on
of course.

alan
_______________________________________________
cisco-nsp mailing list cisco-nsp [at] puck
https://puck.nether.net/mailman/listinfo/cisco-nsp
archive at http://puck.nether.net/pipermail/cisco-nsp/


yurixewx at yahoo

Aug 31, 2009, 3:39 PM

Post #11 of 11 (2449 views)
Permalink
Re: Data VLAN/Voice VLAN [In reply to]

Thanks for all of the replies.

I would like to summarize the information I've gathered so far from this thread. Please correct me if I am wrong on any of this.

* If the switchport is in access mode, you must have a CDP compatible phone and CDP enabled on the switchport. When a cisco phone is connected, the trunk will be negotiated and the voice vlan will be tagged. Data will be untagged and accepted as the configured access vlan.

switchport mode access
switchport access vlan 77
switchport voice vlan 66


*If the switchport is in trunk mode, the configured voice vlan will be tagged in the same way, however the data vlan will be the native vlan configured on the switchport.

switchport mode trunk
switchport trunk allowed vlan 77,66
switchport trunk native vlan 77
switchport voice vlan 66

*If the switch supports LLDP then you can have the same configuration as the first, but with none-cisco phones.

ADD:

globally:

lldp run






--- On Mon, 8/31/09, Alan Buxey <A.L.M.Buxey [at] lboro> wrote:

> From: Alan Buxey <A.L.M.Buxey [at] lboro>
> Subject: Re: [c-nsp] Data VLAN/Voice VLAN
> To: "Bill Blackford" <BBlackford [at] nwresd>
> Cc: "cisco-nsp [at] puck" <cisco-nsp [at] puck>
> Date: Monday, August 31, 2009, 1:51 PM
> Hi,
> > I agree. LLDP is fairly slick. We're currently doing
> it with a non-Cisco switch and Cisco phones in some of our
> smaller sites.
>
> ..and i noted that LLDP is slowly leaking out as a feature
> on cisco switches -
> recent IOS for 3560 and 2960 switches can speak it...
> service needs to be turned on
> of course.
>
> alan
> _______________________________________________
> cisco-nsp mailing list  cisco-nsp [at] puck
> https://puck.nether.net/mailman/listinfo/cisco-nsp
> archive at http://puck.nether.net/pipermail/cisco-nsp/
>



_______________________________________________
cisco-nsp mailing list cisco-nsp [at] puck
https://puck.nether.net/mailman/listinfo/cisco-nsp
archive at http://puck.nether.net/pipermail/cisco-nsp/

Cisco nsp RSS feed   Index | Next | Previous | View Threaded
 
 


Interested in having your list archived? Contact Gossamer Threads
 
  Web Applications & Managed Hosting Powered by Gossamer Threads Inc.