Login | Register For Free | Help
Search for: (Advanced)

Mailing List Archive: Cisco: NAS

as5300 - modem fails to handshake

 

 

Cisco nas RSS feed   Index | Next | Previous | View Threaded


rod at nisny

Jul 12, 2005, 7:43 AM

Post #1 of 3 (2009 views)
Permalink
as5300 - modem fails to handshake

AS5300
IOS 12.3(15)
modem version 2.9.5.0

Only used for incoming dial up

We have 3 ISDN/PRI incoming configured in nfas group. When the first T
reaches 23 lines in use and the calls roll over to the next T, the call
is assigned to a modem, but the modem does NOT initiate handshake sequence.

I know a debug on a bad call would help, unfortunately the create that
sequence of events is problematic. If the opportunity arises I will
post that info as well.

If anyone has any ideas, please let me know.

#show ver
Cisco Internetwork Operating System Software
IOS (tm) 5300 Software (C5300-JS-M), Version 12.3(15), RELEASE SOFTWARE
(fc3)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2005 by cisco Systems, Inc.
Compiled Tue 24-May-05 16:02 by ssearch
Image text-base: 0x60008AEC, data-base: 0x618DA000

ROM: System Bootstrap, Version 11.2(19970724:081727)
[INT-janeiro.weekly.0.5.0 101], INTERIM SOFTWARE
BOOTLDR: 5300 Software (C5300-BOOT-M), Version 12.3(15), RELEASE
SOFTWARE (fc3)

c5300-2 uptime is 4 days, 18 hours, 26 minutes
System returned to ROM by reload at 13:08:23 UTC Thu Jul 7 2005
System image file is "flash:c5300-js-mz.123-15.bin"

cisco AS5300 (R4K) processor (revision A.22) with 131072K/16384K bytes
of memory.
Processor board ID 06465466
R4700 CPU at 150MHz, Implementation 33, Rev 1.0, 512KB L2 Cache
Bridging software.
X.25 software, Version 3.0.0.
SuperLAT software (copyright 1990 by Meridian Technology Corp).
TN3270 Emulation software.
Primary Rate ISDN software, Version 1.1.
Backplane revision 2
Manufacture Cookie Info:
EEPROM Type 0x0001, EEPROM Version 0x01, Board ID 0x30,
Board Hardware Version 1.0, Item Number 73-2414-03,
Board Revision A0, Serial Number 06465466,
PLD/ISP Version <unset>, Manufacture Date 23-Oct-1997.
1 Ethernet/IEEE 802.3 interface(s)
1 FastEthernet/IEEE 802.3 interface(s)
76 Serial network interface(s)
192 terminal line(s)
8 Channelized T1/PRI port(s)
128K bytes of non-volatile configuration memory.
16384K bytes of processor board System flash (Read/Write)
8192K bytes of processor board Boot flash (Read/Write)

Configuration register is 0x2102

#show run
Building configuration...

Current configuration : 3490 bytes
!
version 12.3
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname c5300-2
!
boot-start-marker
boot-end-marker
!
enable secret 5 ***
!
spe 1/0 1/7
firmware location system:/ucode/mica_port_firmware
spe 2/0 2/7
firmware location system:/ucode/mica_port_firmware
!
!
resource-pool disable
!
aaa new-model
aaa session-mib disconnect
!
!
aaa authentication login default group radius local
aaa authentication login console none
aaa authentication ppp default group radius local
aaa authorization network default group radius local
aaa accounting exec default start-stop group radius
aaa accounting connection default start-stop group radius
aaa accounting system default start-stop group radius
aaa session-id common
ip subnet-zero
ip domain name ***.com
ip name-server *.*.*.*
ip name-server *.*.*.*
!
async-bootp dns-server *.*.*.* *.*.*.*
!
isdn switch-type primary-ni
!
!
controller T1 0
framing esf
clock source line primary
linecode b8zs
pri-group timeslots 1-24 nfas_d primary nfas_int 0 nfas_group 1
!
controller T1 1
framing esf
clock source line secondary 1
linecode b8zs
pri-group timeslots 1-24 nfas_d none nfas_int 2 nfas_group 1
!
controller T1 2
framing esf
clock source line secondary 2
linecode b8zs
pri-group timeslots 1-24 nfas_d backup nfas_int 1 nfas_group 1
!
controller T1 3
framing sf
clock source line secondary 3
linecode ami
!
controller T1 4
framing sf
clock source line secondary 4
linecode ami
!
controller T1 5
framing sf
clock source line secondary 5
linecode ami
!
controller T1 6
framing sf
clock source line secondary 6
linecode ami
!
controller T1 7
framing sf
clock source line secondary 7
linecode ami
!
!
interface Ethernet0
ip address *.*.*.* *.*.*.*
!
interface Serial0
no ip address
no ip route-cache
shutdown
clock rate 2015232
no fair-queue
!
interface Serial1
no ip address
no ip route-cache
shutdown
clock rate 2015232
no fair-queue
!
interface Serial2
no ip address
no ip route-cache
shutdown
clock rate 2015232
no fair-queue
!
interface Serial3
no ip address
no ip route-cache
shutdown
clock rate 2015232
no fair-queue
!
interface Serial0:23
ip unnumbered Ethernet0
encapsulation ppp
ip tcp header-compression passive
isdn switch-type primary-ni
isdn incoming-voice modem
peer default ip address pool setup_pool setup_pool2
ppp authentication pap
!
interface FastEthernet0
no ip address
no ip route-cache
shutdown
duplex full
speed auto
!
interface Group-Async1
ip unnumbered Ethernet0
encapsulation ppp
ip tcp header-compression
async mode interactive
peer default ip address pool setup_pool setup_pool2
ppp authentication pap
group-range 1 192
!
ip local pool setup_pool *.*.*.* *.*.*.*
ip local pool setup_pool2 *.*.*.* *.*.*.*
ip default-gateway *.*.*.*
ip classless
ip route 0.0.0.0 0.0.0.0 *.*.*.*
ip http server
!
!
!
!
!
radius-server host *.*.*.* auth-port 1645 acct-port 1646
radius-server directed-request
radius-server key *****
!
!
!
!
line con 0
logging synchronous
transport output all
line 1 192
modem InOut
transport input all
autoselect during-login
autoselect ppp
line aux 0
transport output all
line vty 0 4
transport input all
transport output all
!
end


Aaron at cisco

Jul 12, 2005, 10:39 AM

Post #2 of 3 (1880 views)
Permalink
Re: as5300 - modem fails to handshake [In reply to]

A very typical cause for a symptom like this, when doing
NFAS, is "crossed spans". E.g. your T1 1 goes to
T1 1 on the switch, but your T1 2 goes to the switch's
T1 3 and your T1 3 goes to their T1 2.

If you unplug your T1 2 while you have your switch guy
on the phone, which T1 does *he* see go down?

Aaron

---

>AS5300
>IOS 12.3(15)
>modem version 2.9.5.0
>
>Only used for incoming dial up
>
>We have 3 ISDN/PRI incoming configured in nfas group. When the first T
>reaches 23 lines in use and the calls roll over to the next T, the call
>is assigned to a modem, but the modem does NOT initiate handshake sequence.
>
>I know a debug on a bad call would help, unfortunately the create that
>sequence of events is problematic. If the opportunity arises I will
>post that info as well.
>
>If anyone has any ideas, please let me know.
>
>#show ver
>Cisco Internetwork Operating System Software
>IOS (tm) 5300 Software (C5300-JS-M), Version 12.3(15), RELEASE SOFTWARE
>(fc3)
>Technical Support: http://www.cisco.com/techsupport
>Copyright (c) 1986-2005 by cisco Systems, Inc.
>Compiled Tue 24-May-05 16:02 by ssearch
>Image text-base: 0x60008AEC, data-base: 0x618DA000
>
>ROM: System Bootstrap, Version 11.2(19970724:081727)
>[INT-janeiro.weekly.0.5.0 101], INTERIM SOFTWARE
>BOOTLDR: 5300 Software (C5300-BOOT-M), Version 12.3(15), RELEASE
>SOFTWARE (fc3)
>
>c5300-2 uptime is 4 days, 18 hours, 26 minutes
>System returned to ROM by reload at 13:08:23 UTC Thu Jul 7 2005
>System image file is "flash:c5300-js-mz.123-15.bin"
>
>cisco AS5300 (R4K) processor (revision A.22) with 131072K/16384K bytes
>of memory.
>Processor board ID 06465466
>R4700 CPU at 150MHz, Implementation 33, Rev 1.0, 512KB L2 Cache
>Bridging software.
>X.25 software, Version 3.0.0.
>SuperLAT software (copyright 1990 by Meridian Technology Corp).
>TN3270 Emulation software.
>Primary Rate ISDN software, Version 1.1.
>Backplane revision 2
>Manufacture Cookie Info:
> EEPROM Type 0x0001, EEPROM Version 0x01, Board ID 0x30,
> Board Hardware Version 1.0, Item Number 73-2414-03,
> Board Revision A0, Serial Number 06465466,
> PLD/ISP Version <unset>, Manufacture Date 23-Oct-1997.
>1 Ethernet/IEEE 802.3 interface(s)
>1 FastEthernet/IEEE 802.3 interface(s)
>76 Serial network interface(s)
>192 terminal line(s)
>8 Channelized T1/PRI port(s)
>128K bytes of non-volatile configuration memory.
>16384K bytes of processor board System flash (Read/Write)
>8192K bytes of processor board Boot flash (Read/Write)
>
>Configuration register is 0x2102
>
>#show run
>Building configuration...
>
>Current configuration : 3490 bytes
>!
>version 12.3
>no service pad
>service timestamps debug datetime msec
>service timestamps log datetime msec
>no service password-encryption
>!
>hostname c5300-2
>!
>boot-start-marker
>boot-end-marker
>!
>enable secret 5 ***
>!
>spe 1/0 1/7
> firmware location system:/ucode/mica_port_firmware
>spe 2/0 2/7
> firmware location system:/ucode/mica_port_firmware
>!
>!
>resource-pool disable
>!
>aaa new-model
>aaa session-mib disconnect
>!
>!
>aaa authentication login default group radius local
>aaa authentication login console none
>aaa authentication ppp default group radius local
>aaa authorization network default group radius local
>aaa accounting exec default start-stop group radius
>aaa accounting connection default start-stop group radius
>aaa accounting system default start-stop group radius
>aaa session-id common
>ip subnet-zero
>ip domain name ***.com
>ip name-server *.*.*.*
>ip name-server *.*.*.*
>!
>async-bootp dns-server *.*.*.* *.*.*.*
>!
>isdn switch-type primary-ni
>!
>!
>controller T1 0
> framing esf
> clock source line primary
> linecode b8zs
> pri-group timeslots 1-24 nfas_d primary nfas_int 0 nfas_group 1
>!
>controller T1 1
> framing esf
> clock source line secondary 1
> linecode b8zs
> pri-group timeslots 1-24 nfas_d none nfas_int 2 nfas_group 1
>!
>controller T1 2
> framing esf
> clock source line secondary 2
> linecode b8zs
> pri-group timeslots 1-24 nfas_d backup nfas_int 1 nfas_group 1
>!
>controller T1 3
> framing sf
> clock source line secondary 3
> linecode ami
>!
>controller T1 4
> framing sf
> clock source line secondary 4
> linecode ami
>!
>controller T1 5
> framing sf
> clock source line secondary 5
> linecode ami
>!
>controller T1 6
> framing sf
> clock source line secondary 6
> linecode ami
>!
>controller T1 7
> framing sf
> clock source line secondary 7
> linecode ami
>!
>!
>interface Ethernet0
> ip address *.*.*.* *.*.*.*
>!
>interface Serial0
> no ip address
> no ip route-cache
> shutdown
> clock rate 2015232
> no fair-queue
>!
>interface Serial1
> no ip address
> no ip route-cache
> shutdown
> clock rate 2015232
> no fair-queue
>!
>interface Serial2
> no ip address
> no ip route-cache
> shutdown
> clock rate 2015232
> no fair-queue
>!
>interface Serial3
> no ip address
> no ip route-cache
> shutdown
> clock rate 2015232
> no fair-queue
>!
>interface Serial0:23
> ip unnumbered Ethernet0
> encapsulation ppp
> ip tcp header-compression passive
> isdn switch-type primary-ni
> isdn incoming-voice modem
> peer default ip address pool setup_pool setup_pool2
> ppp authentication pap
>!
>interface FastEthernet0
> no ip address
> no ip route-cache
> shutdown
> duplex full
> speed auto
>!
>interface Group-Async1
> ip unnumbered Ethernet0
> encapsulation ppp
> ip tcp header-compression
> async mode interactive
> peer default ip address pool setup_pool setup_pool2
> ppp authentication pap
> group-range 1 192
>!
>ip local pool setup_pool *.*.*.* *.*.*.*
>ip local pool setup_pool2 *.*.*.* *.*.*.*
>ip default-gateway *.*.*.*
>ip classless
>ip route 0.0.0.0 0.0.0.0 *.*.*.*
>ip http server
>!
>!
>!
>!
>!
>radius-server host *.*.*.* auth-port 1645 acct-port 1646
>radius-server directed-request
>radius-server key *****
>!
>!
>!
>!
>line con 0
> logging synchronous
> transport output all
>line 1 192
> modem InOut
> transport input all
> autoselect during-login
> autoselect ppp
>line aux 0
> transport output all
>line vty 0 4
> transport input all
> transport output all
>!
>end
>
>_______________________________________________
>cisco-nas mailing list
>cisco-nas [at] puck
>https://puck.nether.net/mailman/listinfo/cisco-nas
>
>


rod at nisny

Jul 12, 2005, 11:18 AM

Post #3 of 3 (1877 views)
Permalink
Re: as5300 - modem fails to handshake [In reply to]

Aaron,

Thanks, but that wasn't it.

Rod

> A very typical cause for a symptom like this, when doing
> NFAS, is "crossed spans". E.g. your T1 1 goes to
> T1 1 on the switch, but your T1 2 goes to the switch's
> T1 3 and your T1 3 goes to their T1 2.
>
> If you unplug your T1 2 while you have your switch guy
> on the phone, which T1 does *he* see go down?
>
> Aaron
>
> ---
>
>>AS5300
>>IOS 12.3(15)
>>modem version 2.9.5.0
>>
>>Only used for incoming dial up
>>
>>We have 3 ISDN/PRI incoming configured in nfas group. When the first T
>>reaches 23 lines in use and the calls roll over to the next T, the call
>>is assigned to a modem, but the modem does NOT initiate handshake
>> sequence.
>>
>>I know a debug on a bad call would help, unfortunately the create that
>>sequence of events is problematic. If the opportunity arises I will
>>post that info as well.
>>
>>If anyone has any ideas, please let me know.
>>
>>#show ver
>>Cisco Internetwork Operating System Software
>>IOS (tm) 5300 Software (C5300-JS-M), Version 12.3(15), RELEASE SOFTWARE
>>(fc3)
>>Technical Support: http://www.cisco.com/techsupport
>>Copyright (c) 1986-2005 by cisco Systems, Inc.
>>Compiled Tue 24-May-05 16:02 by ssearch
>>Image text-base: 0x60008AEC, data-base: 0x618DA000
>>
>>ROM: System Bootstrap, Version 11.2(19970724:081727)
>>[INT-janeiro.weekly.0.5.0 101], INTERIM SOFTWARE
>>BOOTLDR: 5300 Software (C5300-BOOT-M), Version 12.3(15), RELEASE
>>SOFTWARE (fc3)
>>
>>c5300-2 uptime is 4 days, 18 hours, 26 minutes
>>System returned to ROM by reload at 13:08:23 UTC Thu Jul 7 2005
>>System image file is "flash:c5300-js-mz.123-15.bin"
>>
>>cisco AS5300 (R4K) processor (revision A.22) with 131072K/16384K bytes
>>of memory.
>>Processor board ID 06465466
>>R4700 CPU at 150MHz, Implementation 33, Rev 1.0, 512KB L2 Cache
>>Bridging software.
>>X.25 software, Version 3.0.0.
>>SuperLAT software (copyright 1990 by Meridian Technology Corp).
>>TN3270 Emulation software.
>>Primary Rate ISDN software, Version 1.1.
>>Backplane revision 2
>>Manufacture Cookie Info:
>> EEPROM Type 0x0001, EEPROM Version 0x01, Board ID 0x30,
>> Board Hardware Version 1.0, Item Number 73-2414-03,
>> Board Revision A0, Serial Number 06465466,
>> PLD/ISP Version <unset>, Manufacture Date 23-Oct-1997.
>>1 Ethernet/IEEE 802.3 interface(s)
>>1 FastEthernet/IEEE 802.3 interface(s)
>>76 Serial network interface(s)
>>192 terminal line(s)
>>8 Channelized T1/PRI port(s)
>>128K bytes of non-volatile configuration memory.
>>16384K bytes of processor board System flash (Read/Write)
>>8192K bytes of processor board Boot flash (Read/Write)
>>
>>Configuration register is 0x2102
>>
>>#show run
>>Building configuration...
>>
>>Current configuration : 3490 bytes
>>!
>>version 12.3
>>no service pad
>>service timestamps debug datetime msec
>>service timestamps log datetime msec
>>no service password-encryption
>>!
>>hostname c5300-2
>>!
>>boot-start-marker
>>boot-end-marker
>>!
>>enable secret 5 ***
>>!
>>spe 1/0 1/7
>> firmware location system:/ucode/mica_port_firmware
>>spe 2/0 2/7
>> firmware location system:/ucode/mica_port_firmware
>>!
>>!
>>resource-pool disable
>>!
>>aaa new-model
>>aaa session-mib disconnect
>>!
>>!
>>aaa authentication login default group radius local
>>aaa authentication login console none
>>aaa authentication ppp default group radius local
>>aaa authorization network default group radius local
>>aaa accounting exec default start-stop group radius
>>aaa accounting connection default start-stop group radius
>>aaa accounting system default start-stop group radius
>>aaa session-id common
>>ip subnet-zero
>>ip domain name ***.com
>>ip name-server *.*.*.*
>>ip name-server *.*.*.*
>>!
>>async-bootp dns-server *.*.*.* *.*.*.*
>>!
>>isdn switch-type primary-ni
>>!
>>!
>>controller T1 0
>> framing esf
>> clock source line primary
>> linecode b8zs
>> pri-group timeslots 1-24 nfas_d primary nfas_int 0 nfas_group 1
>>!
>>controller T1 1
>> framing esf
>> clock source line secondary 1
>> linecode b8zs
>> pri-group timeslots 1-24 nfas_d none nfas_int 2 nfas_group 1
>>!
>>controller T1 2
>> framing esf
>> clock source line secondary 2
>> linecode b8zs
>> pri-group timeslots 1-24 nfas_d backup nfas_int 1 nfas_group 1
>>!
>>controller T1 3
>> framing sf
>> clock source line secondary 3
>> linecode ami
>>!
>>controller T1 4
>> framing sf
>> clock source line secondary 4
>> linecode ami
>>!
>>controller T1 5
>> framing sf
>> clock source line secondary 5
>> linecode ami
>>!
>>controller T1 6
>> framing sf
>> clock source line secondary 6
>> linecode ami
>>!
>>controller T1 7
>> framing sf
>> clock source line secondary 7
>> linecode ami
>>!
>>!
>>interface Ethernet0
>> ip address *.*.*.* *.*.*.*
>>!
>>interface Serial0
>> no ip address
>> no ip route-cache
>> shutdown
>> clock rate 2015232
>> no fair-queue
>>!
>>interface Serial1
>> no ip address
>> no ip route-cache
>> shutdown
>> clock rate 2015232
>> no fair-queue
>>!
>>interface Serial2
>> no ip address
>> no ip route-cache
>> shutdown
>> clock rate 2015232
>> no fair-queue
>>!
>>interface Serial3
>> no ip address
>> no ip route-cache
>> shutdown
>> clock rate 2015232
>> no fair-queue
>>!
>>interface Serial0:23
>> ip unnumbered Ethernet0
>> encapsulation ppp
>> ip tcp header-compression passive
>> isdn switch-type primary-ni
>> isdn incoming-voice modem
>> peer default ip address pool setup_pool setup_pool2
>> ppp authentication pap
>>!
>>interface FastEthernet0
>> no ip address
>> no ip route-cache
>> shutdown
>> duplex full
>> speed auto
>>!
>>interface Group-Async1
>> ip unnumbered Ethernet0
>> encapsulation ppp
>> ip tcp header-compression
>> async mode interactive
>> peer default ip address pool setup_pool setup_pool2
>> ppp authentication pap
>> group-range 1 192
>>!
>>ip local pool setup_pool *.*.*.* *.*.*.*
>>ip local pool setup_pool2 *.*.*.* *.*.*.*
>>ip default-gateway *.*.*.*
>>ip classless
>>ip route 0.0.0.0 0.0.0.0 *.*.*.*
>>ip http server
>>!
>>!
>>!
>>!
>>!
>>radius-server host *.*.*.* auth-port 1645 acct-port 1646
>>radius-server directed-request
>>radius-server key *****
>>!
>>!
>>!
>>!
>>line con 0
>> logging synchronous
>> transport output all
>>line 1 192
>> modem InOut
>> transport input all
>> autoselect during-login
>> autoselect ppp
>>line aux 0
>> transport output all
>>line vty 0 4
>> transport input all
>> transport output all
>>!
>>end
>>
>>_______________________________________________
>>cisco-nas mailing list
>>cisco-nas [at] puck
>>https://puck.nether.net/mailman/listinfo/cisco-nas
>>
>>
>
>

Cisco nas RSS feed   Index | Next | Previous | View Threaded
 
 


Interested in having your list archived? Contact Gossamer Threads
 
  Web Applications & Managed Hosting Powered by Gossamer Threads Inc.