Login | Register For Free | Help
Search for: (Advanced)

Mailing List Archive: Cisco: BBA

A static DHCP entry for a PPPoE customer

 

 

Cisco bba RSS feed   Index | Next | Previous | View Threaded


junaid.x86 at gmail

Jan 2, 2008, 10:25 AM

Post #1 of 3 (1838 views)
Permalink
A static DHCP entry for a PPPoE customer

Hi,

I am trying to assign IP addresses to PPPoE customer via local DHCP
pool on my BRAS. But I want to one customer to get a fixed IP address
everytime. I tried to fix the address on the basis of
mac/client-identifier but in vain. Any one did something similar or
any idea how to get this done?

My pertinent configs are as follows. I am able to get IP address from
the second pool "naeem" and I was even able to assign a fixed IP using
a similar configuration (using client-identifier) from the Ethernet
(LAN) interface of the router but I guess the DHCP request is a bit
different in this scenario.

vpdn enable
!
vpdn-group 1
accept-dialin
protocol pppoe
virtual-template 1

interface Virtual-Template1
ip unnumbered Loopback0
peer default ip address dhcp-pool imti naeem
ppp authentication pap



ip dhcp pool imti
host 172.16.255.129 255.255.255.0
hardware-address 6a75.6e61.6964
domain-name somedomain.com
dns-server 172.16.1.102 172.16.2.102
default-router 172.16.255.254
!
ip dhcp pool naeem
network 172.16.255.0 255.255.255.0
domain-name somedomain.com
dns-server 172.16.1.102 172.16.2.102
default-router 172.16.255.254



--


Regards,

Junaid
_______________________________________________
cisco-bba mailing list
cisco-bba [at] puck
https://puck.nether.net/mailman/listinfo/cisco-bba


andresarias at geonet

Jan 2, 2008, 1:54 PM

Post #2 of 3 (1732 views)
Permalink
Re: A static DHCP entry for a PPPoE customer [In reply to]

You can use Radius Server to deliver Fixed IP to users with pppoe
connections.

http://www.cisco.com/en/US/products/ps6350/products_configuration_guide_chap
ter09186a00804ec60a.html#wp1033311





Andres Felipe Arias G.

Coordinador de Infraestructura y Conectividad

Coldecon S.A - Regional Norte

Telefono: (574) 315 18 10

Movil:311-7461084/315-8465293(Plan Cia)

Msn:andres.felipe.arias [at] hotmail

Direccion: Cr 43F # 14-13

Medellin-Colombia

-----Mensaje original-----
De: cisco-bba-bounces [at] puck
[mailto:cisco-bba-bounces [at] puck] En nombre de Junaid
Enviado el: miércoles, 02 de enero de 2008 13:26
Para: cisco-bba [at] puck
Asunto: [cisco-bba] A static DHCP entry for a PPPoE customer

Hi,

I am trying to assign IP addresses to PPPoE customer via local DHCP
pool on my BRAS. But I want to one customer to get a fixed IP address
everytime. I tried to fix the address on the basis of
mac/client-identifier but in vain. Any one did something similar or
any idea how to get this done?

My pertinent configs are as follows. I am able to get IP address from
the second pool "naeem" and I was even able to assign a fixed IP using
a similar configuration (using client-identifier) from the Ethernet
(LAN) interface of the router but I guess the DHCP request is a bit
different in this scenario.

vpdn enable
!
vpdn-group 1
accept-dialin
protocol pppoe
virtual-template 1

interface Virtual-Template1
ip unnumbered Loopback0
peer default ip address dhcp-pool imti naeem
ppp authentication pap



ip dhcp pool imti
host 172.16.255.129 255.255.255.0
hardware-address 6a75.6e61.6964
domain-name somedomain.com
dns-server 172.16.1.102 172.16.2.102
default-router 172.16.255.254
!
ip dhcp pool naeem
network 172.16.255.0 255.255.255.0
domain-name somedomain.com
dns-server 172.16.1.102 172.16.2.102
default-router 172.16.255.254



--


Regards,

Junaid
_______________________________________________
cisco-bba mailing list
cisco-bba [at] puck
https://puck.nether.net/mailman/listinfo/cisco-bba

_______________________________________________
cisco-bba mailing list
cisco-bba [at] puck
https://puck.nether.net/mailman/listinfo/cisco-bba


junaid.x86 at gmail

Jan 2, 2008, 11:24 PM

Post #3 of 3 (1729 views)
Permalink
Re: A static DHCP entry for a PPPoE customer [In reply to]

Thank you for your input but I really need to find a solution with
DHCP. Any way I can fix the addresses for a few clients and let the
rest get addresses from a pool but all this via DHCP.

--


Regards,

Junaid



On Jan 3, 2008 2:54 AM, Andres Felipe Arias G.
<andresarias [at] geonet> wrote:
> You can use Radius Server to deliver Fixed IP to users with pppoe
> connections.
>
> http://www.cisco.com/en/US/products/ps6350/products_configuration_guide_chap
> ter09186a00804ec60a.html#wp1033311
>
>
>
>
>
> Andres Felipe Arias G.
>
> Coordinador de Infraestructura y Conectividad
>
> Coldecon S.A - Regional Norte
>
> Telefono: (574) 315 18 10
>
> Movil:311-7461084/315-8465293(Plan Cia)
>
> Msn:andres.felipe.arias [at] hotmail
>
> Direccion: Cr 43F # 14-13
>
> Medellin-Colombia
>
> -----Mensaje original-----
> De: cisco-bba-bounces [at] puck
> [mailto:cisco-bba-bounces [at] puck] En nombre de Junaid
> Enviado el: miércoles, 02 de enero de 2008 13:26
> Para: cisco-bba [at] puck
> Asunto: [cisco-bba] A static DHCP entry for a PPPoE customer
>
>
> Hi,
>
> I am trying to assign IP addresses to PPPoE customer via local DHCP
> pool on my BRAS. But I want to one customer to get a fixed IP address
> everytime. I tried to fix the address on the basis of
> mac/client-identifier but in vain. Any one did something similar or
> any idea how to get this done?
>
> My pertinent configs are as follows. I am able to get IP address from
> the second pool "naeem" and I was even able to assign a fixed IP using
> a similar configuration (using client-identifier) from the Ethernet
> (LAN) interface of the router but I guess the DHCP request is a bit
> different in this scenario.
>
> vpdn enable
> !
> vpdn-group 1
> accept-dialin
> protocol pppoe
> virtual-template 1
>
> interface Virtual-Template1
> ip unnumbered Loopback0
> peer default ip address dhcp-pool imti naeem
> ppp authentication pap
>
>
>
> ip dhcp pool imti
> host 172.16.255.129 255.255.255.0
> hardware-address 6a75.6e61.6964
> domain-name somedomain.com
> dns-server 172.16.1.102 172.16.2.102
> default-router 172.16.255.254
> !
> ip dhcp pool naeem
> network 172.16.255.0 255.255.255.0
> domain-name somedomain.com
> dns-server 172.16.1.102 172.16.2.102
> default-router 172.16.255.254
>
>
>
> --
>
>
> Regards,
>
> Junaid
> _______________________________________________
> cisco-bba mailing list
> cisco-bba [at] puck
> https://puck.nether.net/mailman/listinfo/cisco-bba
>
>
_______________________________________________
cisco-bba mailing list
cisco-bba [at] puck
https://puck.nether.net/mailman/listinfo/cisco-bba

Cisco bba RSS feed   Index | Next | Previous | View Threaded
 
 


Interested in having your list archived? Contact Gossamer Threads
 
  Web Applications & Managed Hosting Powered by Gossamer Threads Inc.