Login | Register For Free | Help
Search for: (Advanced)

Mailing List Archive: Cisco: BBA

IPv6 PPPoE clients into VRF

 

 

Cisco bba RSS feed   Index | Next | Previous | View Threaded


rado at dev

Feb 4, 2011, 8:49 AM

Post #1 of 3 (2883 views)
Permalink
IPv6 PPPoE clients into VRF

Hello,



I'm wondering if it's currently possible to insert a dual-stack IPv4/IPv6
PPPoE session into a VRF?



My setup is very straightforward with a fixed IPv4 address and stateless WAN
IPv6 address (no need to worry about LAN addressing at the moment).

I'd like to provision user's configuration through a RADIUS profile:



User-Name = "rado2 [at] shds"

Framed-IP-Netmask = 255.255.255.255

Framed-IP-Address = 10.10.10.20

Cisco-AVPair = "ipv6:prefix#1=2a01:148:900:5::/64"

Framed-Protocol = PPP

Service-Type = Framed-User



The VRF is configured on my testlab router as:



vrf definition ZZZ

rd 100:100

!

address-family ipv4

route-target export 100:100

route-target import 100:100

exit-address-family

!

address-family ipv6

route-target export 100:100

route-target import 100:100

exit-address-family



interface Loopback200

vrf forwarding ZZZ

ip address 10.198.0.1 255.255.255.255

ipv6 address 2A01:148:900:4::3/128

end



IOS used on the BRAS is: C7301-ADVIPSERVICESK9-M), Version 12.2(33)SRD4.

Device hardware is Cisco 7301.



We'd usually use the following RADIUS profile lines when configuring an IPv4
only customer, but that doesn't seem to work when the customer is a
dual-stack PPPoE session.





Cisco-AVPair = "lcp:interface-config#1=ip vrf forwarding ZZZ"

Cisco-AVPair = "lcp:interface-config#2=ip unnumbered Loopback200"



Thanks for you help!



Kind Regards,

Rado


achatz at forthnet

Feb 7, 2011, 10:20 AM

Post #2 of 3 (2770 views)
Permalink
Re: IPv6 PPPoE clients into VRF [In reply to]

Have you tried the following?


Cisco-AVPair = "lcp:interface-config#1=vrf forwarding ZZZ"

Cisco-AVPair = "lcp:interface-config#2=ipv6 unnumbered Loopback200"


--
Tassos



Rado Vasilev wrote on 04/02/2011 18:49:
>
> Hello,
>
> I’m wondering if it’s currently possible to insert a dual-stack
> IPv4/IPv6 PPPoE session into a VRF?
>
> My setup is very straightforward with a fixed IPv4 address and
> stateless WAN IPv6 address (no need to worry about LAN addressing at
> the moment).
>
> I’d like to provision user’s configuration through a RADIUS profile:
>
> User-Name = "rado2 [at] shds"
>
> Framed-IP-Netmask = 255.255.255.255
>
> Framed-IP-Address = 10.10.10.20
>
> Cisco-AVPair = "ipv6:prefix#1=2a01:148:900:5::/64"
>
> Framed-Protocol = PPP
>
> Service-Type = Framed-User
>
> The VRF is configured on my testlab router as:
>
> vrf definition ZZZ
>
> rd 100:100
>
> !
>
> address-family ipv4
>
> route-target export 100:100
>
> route-target import 100:100
>
> exit-address-family
>
> !
>
> address-family ipv6
>
> route-target export 100:100
>
> route-target import 100:100
>
> exit-address-family
>
> interface Loopback200
>
> vrf forwarding ZZZ
>
> ip address 10.198.0.1 255.255.255.255
>
> ipv6 address 2A01:148:900:4::3/128
>
> end
>
> IOS used on the BRAS is: C7301-ADVIPSERVICESK9-M), Version 12.2(33)SRD4.
>
> Device hardware is Cisco 7301.
>
> We’d usually use the following RADIUS profile lines when configuring
> an IPv4 only customer, but that doesn’t seem to work when the customer
> is a dual-stack PPPoE session.
>
> Cisco-AVPair = "lcp:interface-config#1=ip vrf forwarding ZZZ"
>
> Cisco-AVPair = "lcp:interface-config#2=ip unnumbered Loopback200"
>
> Thanks for you help!
>
> Kind Regards,
>
> Rado
>
>
> _______________________________________________
> cisco-bba mailing list
> cisco-bba [at] puck
> https://puck.nether.net/mailman/listinfo/cisco-bba
_______________________________________________
cisco-bba mailing list
cisco-bba [at] puck
https://puck.nether.net/mailman/listinfo/cisco-bba


rado at dev

Feb 11, 2011, 8:45 AM

Post #3 of 3 (2754 views)
Permalink
Re: IPv6 PPPoE clients into VRF [In reply to]

Hiya,

It doesn't work with those lines added.
I've contacted our Cisco SE and will update the list when/if I make it work
:)

Regards,
Rado

-----Original Message-----
From: cisco-bba-bounces [at] puck
[mailto:cisco-bba-bounces [at] puck] On Behalf Of Tassos
Chatzithomaoglou
Sent: 07 February 2011 18:20
To: cisco-bba [at] puck
Subject: Re: [cisco-bba] IPv6 PPPoE clients into VRF

Have you tried the following?


Cisco-AVPair = "lcp:interface-config#1=vrf forwarding ZZZ"

Cisco-AVPair = "lcp:interface-config#2=ipv6 unnumbered Loopback200"


--
Tassos



Rado Vasilev wrote on 04/02/2011 18:49:
>
> Hello,
>
> I'm wondering if it's currently possible to insert a dual-stack
> IPv4/IPv6 PPPoE session into a VRF?
>
> My setup is very straightforward with a fixed IPv4 address and
> stateless WAN IPv6 address (no need to worry about LAN addressing at
> the moment).
>
> I'd like to provision user's configuration through a RADIUS profile:
>
> User-Name = "rado2 [at] shds"
>
> Framed-IP-Netmask = 255.255.255.255
>
> Framed-IP-Address = 10.10.10.20
>
> Cisco-AVPair = "ipv6:prefix#1=2a01:148:900:5::/64"
>
> Framed-Protocol = PPP
>
> Service-Type = Framed-User
>
> The VRF is configured on my testlab router as:
>
> vrf definition ZZZ
>
> rd 100:100
>
> !
>
> address-family ipv4
>
> route-target export 100:100
>
> route-target import 100:100
>
> exit-address-family
>
> !
>
> address-family ipv6
>
> route-target export 100:100
>
> route-target import 100:100
>
> exit-address-family
>
> interface Loopback200
>
> vrf forwarding ZZZ
>
> ip address 10.198.0.1 255.255.255.255
>
> ipv6 address 2A01:148:900:4::3/128
>
> end
>
> IOS used on the BRAS is: C7301-ADVIPSERVICESK9-M), Version 12.2(33)SRD4.
>
> Device hardware is Cisco 7301.
>
> We'd usually use the following RADIUS profile lines when configuring
> an IPv4 only customer, but that doesn't seem to work when the customer
> is a dual-stack PPPoE session.
>
> Cisco-AVPair = "lcp:interface-config#1=ip vrf forwarding ZZZ"
>
> Cisco-AVPair = "lcp:interface-config#2=ip unnumbered Loopback200"
>
> Thanks for you help!
>
> Kind Regards,
>
> Rado
>
>
> _______________________________________________
> cisco-bba mailing list
> cisco-bba [at] puck
> https://puck.nether.net/mailman/listinfo/cisco-bba
_______________________________________________
cisco-bba mailing list
cisco-bba [at] puck
https://puck.nether.net/mailman/listinfo/cisco-bba

_______________________________________________
cisco-bba mailing list
cisco-bba [at] puck
https://puck.nether.net/mailman/listinfo/cisco-bba

Cisco bba RSS feed   Index | Next | Previous | View Threaded
 
 


Interested in having your list archived? Contact Gossamer Threads
 
  Web Applications & Managed Hosting Powered by Gossamer Threads Inc.