Login | Register For Free | Help
Search for: (Advanced)

Mailing List Archive: Cherokee: users

HTTPS problem

 

 

Cherokee users RSS feed   Index | Next | Previous | View Threaded


gianpietro.germi at bertel

Dec 20, 2011, 2:11 AM

Post #1 of 4 (410 views)
Permalink
HTTPS problem

Hi,
I installed Cherokee 1.2.98 on a VM Fedora 15 :
configure with my options (without Python), make, make install.
Since I don't want to use Python, I copied cherokee.conf from my PC
(created with cherokee-admin and Python): there is only a Virtual server
for both HTTP and HTTPS (with my certificate).
In this case Cherokee correctly works, both for HTTP and HTTPS.

Next step was to install Cherokee (as above) on another Linux machine.
In this case Cherokee works correctly for HTTP, but with HTTPS I get
this error (from GDB):

############################# START ###############################
Cherokee Web Server 1.2.98 (Dec 20 2011): Listening on ports
ALL:443(TLS),
ALL:80, with TLS support via libssl, IPv6 disabled, using epoll, 4096
fds system limit, max. 2041 connections, 5 threads, 408 connections per
thread, standard scheduling policy

####################### HTTPS ERRORS ##############################
Cherokee feels panic!
The Cherokee 'panic action' script, /usr/local/bin/cherokee-panic,
was called for pid 890 (/usr/local/sbin/cherokee-worker).

Below is a backtrace for this process generated with gdb, which shows
the state of the program at the time the error occured. You are
encouraged to submit this information as a bug report in the Cherokee
bug traq system: http://bugs.cherokee-project.com

Operating System: Linux (none) 2.6.34.9-svn25 #5 Thu Dec 15 16:24:48 CET
2011 p
pc GNU/Linux
Debugger: /usr/local/bin/gdb

Using host libthread_db library "/usr/local/lib/libthread_db.so.1".
0x480fb87c in epoll_wait () from /lib/libc.so.6
$1 = 0xff6a59c "1.2.98"
The program is running. Quit anyway (and detach it)? (y or n) [answered
Y; input not from terminal]
PID 890: received a signal=6
########################## HTTPS ERROR #############################

Any idea? I miss some modules or I have to update some library?

Thanks a lot,
G.

_______________________________________________
Cherokee mailing list
Cherokee [at] lists
http://lists.octality.com/listinfo/cherokee


cperrin88 at gmail

Dec 20, 2011, 2:59 AM

Post #2 of 4 (385 views)
Permalink
Re: HTTPS problem [In reply to]

Hi,

It might seem like a dumb question but is openssl installed on the machine?
The webinterface doesn't let you use SSL if it's not installed but you
copied the .conf. I don't know but maybe cherokee doesn't check if the
lib is available since the webinterface does.

Am 20.12.2011 11:11, schrieb gianpietro germi:
> Hi,
> I installed Cherokee 1.2.98 on a VM Fedora 15 :
> configure with my options (without Python), make, make install.
> Since I don't want to use Python, I copied cherokee.conf from my PC
> (created with cherokee-admin and Python): there is only a Virtual server
> for both HTTP and HTTPS (with my certificate).
> In this case Cherokee correctly works, both for HTTP and HTTPS.
>
> Next step was to install Cherokee (as above) on another Linux machine.
> In this case Cherokee works correctly for HTTP, but with HTTPS I get
> this error (from GDB):
>
> ############################# START ###############################
> Cherokee Web Server 1.2.98 (Dec 20 2011): Listening on ports
> ALL:443(TLS),
> ALL:80, with TLS support via libssl, IPv6 disabled, using epoll, 4096
> fds system limit, max. 2041 connections, 5 threads, 408 connections per
> thread, standard scheduling policy
>
> ####################### HTTPS ERRORS ##############################
> Cherokee feels panic!
> The Cherokee 'panic action' script, /usr/local/bin/cherokee-panic,
> was called for pid 890 (/usr/local/sbin/cherokee-worker).
>
> Below is a backtrace for this process generated with gdb, which shows
> the state of the program at the time the error occured. You are
> encouraged to submit this information as a bug report in the Cherokee
> bug traq system: http://bugs.cherokee-project.com
>
> Operating System: Linux (none) 2.6.34.9-svn25 #5 Thu Dec 15 16:24:48 CET
> 2011 p
> pc GNU/Linux
> Debugger: /usr/local/bin/gdb
>
> Using host libthread_db library "/usr/local/lib/libthread_db.so.1".
> 0x480fb87c in epoll_wait () from /lib/libc.so.6
> $1 = 0xff6a59c "1.2.98"
> The program is running. Quit anyway (and detach it)? (y or n) [answered
> Y; input not from terminal]
> PID 890: received a signal=6
> ########################## HTTPS ERROR #############################
>
> Any idea? I miss some modules or I have to update some library?
>
> Thanks a lot,
> G.
>
> _______________________________________________
> Cherokee mailing list
> Cherokee [at] lists
> http://lists.octality.com/listinfo/cherokee

_______________________________________________
Cherokee mailing list
Cherokee [at] lists
http://lists.octality.com/listinfo/cherokee


gianpietro.germi at bertel

Dec 20, 2011, 3:16 AM

Post #3 of 4 (384 views)
Permalink
Re: HTTPS problem [In reply to]

Hi,
the openssl is installed (I use libssl.so.0.9.8 and libcrypto.so.0.9.8).

I'm not sure that the versions used by the two Linux machine are the
same, but the libssl is present on both.

Thanks,
G.

On Tue, 2011-12-20 at 11:59 +0100, Christopher Perrin wrote:
> Hi,
>
> It might seem like a dumb question but is openssl installed on the machine?
> The webinterface doesn't let you use SSL if it's not installed but you
> copied the .conf. I don't know but maybe cherokee doesn't check if the
> lib is available since the webinterface does.
>
> Am 20.12.2011 11:11, schrieb gianpietro germi:
> > Hi,
> > I installed Cherokee 1.2.98 on a VM Fedora 15 :
> > configure with my options (without Python), make, make install.
> > Since I don't want to use Python, I copied cherokee.conf from my PC
> > (created with cherokee-admin and Python): there is only a Virtual server
> > for both HTTP and HTTPS (with my certificate).
> > In this case Cherokee correctly works, both for HTTP and HTTPS.
> >
> > Next step was to install Cherokee (as above) on another Linux machine.
> > In this case Cherokee works correctly for HTTP, but with HTTPS I get
> > this error (from GDB):
> >
> > ############################# START ###############################
> > Cherokee Web Server 1.2.98 (Dec 20 2011): Listening on ports
> > ALL:443(TLS),
> > ALL:80, with TLS support via libssl, IPv6 disabled, using epoll, 4096
> > fds system limit, max. 2041 connections, 5 threads, 408 connections per
> > thread, standard scheduling policy
> >
> > ####################### HTTPS ERRORS ##############################
> > Cherokee feels panic!
> > The Cherokee 'panic action' script, /usr/local/bin/cherokee-panic,
> > was called for pid 890 (/usr/local/sbin/cherokee-worker).
> >
> > Below is a backtrace for this process generated with gdb, which shows
> > the state of the program at the time the error occured. You are
> > encouraged to submit this information as a bug report in the Cherokee
> > bug traq system: http://bugs.cherokee-project.com
> >
> > Operating System: Linux (none) 2.6.34.9-svn25 #5 Thu Dec 15 16:24:48 CET
> > 2011 p
> > pc GNU/Linux
> > Debugger: /usr/local/bin/gdb
> >
> > Using host libthread_db library "/usr/local/lib/libthread_db.so.1".
> > 0x480fb87c in epoll_wait () from /lib/libc.so.6
> > $1 = 0xff6a59c "1.2.98"
> > The program is running. Quit anyway (and detach it)? (y or n) [answered
> > Y; input not from terminal]
> > PID 890: received a signal=6
> > ########################## HTTPS ERROR #############################
> >
> > Any idea? I miss some modules or I have to update some library?
> >
> > Thanks a lot,
> > G.
> >
> > _______________________________________________
> > Cherokee mailing list
> > Cherokee [at] lists
> > http://lists.octality.com/listinfo/cherokee
>
> _______________________________________________
> Cherokee mailing list
> Cherokee [at] lists
> http://lists.octality.com/listinfo/cherokee


_______________________________________________
Cherokee mailing list
Cherokee [at] lists
http://lists.octality.com/listinfo/cherokee


gianpietro.germi at bertel

Dec 21, 2011, 1:34 AM

Post #4 of 4 (381 views)
Permalink
Re: HTTPS problem [In reply to]

Hi,
I forgot an important information.

I use the same Cherokee installation on two different architectures:
HTTPS works well with i386 Linux Machine, I have a problem with PowerPc
Linux machine.

Thanks,
G.

On Tue, 2011-12-20 at 12:16 +0100, gianpietro germi wrote:
> Hi,
> the openssl is installed (I use libssl.so.0.9.8 and libcrypto.so.0.9.8).
>
> I'm not sure that the versions used by the two Linux machine are the
> same, but the libssl is present on both.
>
> Thanks,
> G.
>
> On Tue, 2011-12-20 at 11:59 +0100, Christopher Perrin wrote:
> > Hi,
> >
> > It might seem like a dumb question but is openssl installed on the machine?
> > The webinterface doesn't let you use SSL if it's not installed but you
> > copied the .conf. I don't know but maybe cherokee doesn't check if the
> > lib is available since the webinterface does.
> >
> > Am 20.12.2011 11:11, schrieb gianpietro germi:
> > > Hi,
> > > I installed Cherokee 1.2.98 on a VM Fedora 15 :
> > > configure with my options (without Python), make, make install.
> > > Since I don't want to use Python, I copied cherokee.conf from my PC
> > > (created with cherokee-admin and Python): there is only a Virtual server
> > > for both HTTP and HTTPS (with my certificate).
> > > In this case Cherokee correctly works, both for HTTP and HTTPS.
> > >
> > > Next step was to install Cherokee (as above) on another Linux machine.
> > > In this case Cherokee works correctly for HTTP, but with HTTPS I get
> > > this error (from GDB):
> > >
> > > ############################# START ###############################
> > > Cherokee Web Server 1.2.98 (Dec 20 2011): Listening on ports
> > > ALL:443(TLS),
> > > ALL:80, with TLS support via libssl, IPv6 disabled, using epoll, 4096
> > > fds system limit, max. 2041 connections, 5 threads, 408 connections per
> > > thread, standard scheduling policy
> > >
> > > ####################### HTTPS ERRORS ##############################
> > > Cherokee feels panic!
> > > The Cherokee 'panic action' script, /usr/local/bin/cherokee-panic,
> > > was called for pid 890 (/usr/local/sbin/cherokee-worker).
> > >
> > > Below is a backtrace for this process generated with gdb, which shows
> > > the state of the program at the time the error occured. You are
> > > encouraged to submit this information as a bug report in the Cherokee
> > > bug traq system: http://bugs.cherokee-project.com
> > >
> > > Operating System: Linux (none) 2.6.34.9-svn25 #5 Thu Dec 15 16:24:48 CET
> > > 2011 p
> > > pc GNU/Linux
> > > Debugger: /usr/local/bin/gdb
> > >
> > > Using host libthread_db library "/usr/local/lib/libthread_db.so.1".
> > > 0x480fb87c in epoll_wait () from /lib/libc.so.6
> > > $1 = 0xff6a59c "1.2.98"
> > > The program is running. Quit anyway (and detach it)? (y or n) [answered
> > > Y; input not from terminal]
> > > PID 890: received a signal=6
> > > ########################## HTTPS ERROR #############################
> > >
> > > Any idea? I miss some modules or I have to update some library?
> > >
> > > Thanks a lot,
> > > G.
> > >
> > > _______________________________________________
> > > Cherokee mailing list
> > > Cherokee [at] lists
> > > http://lists.octality.com/listinfo/cherokee
> >
> > _______________________________________________
> > Cherokee mailing list
> > Cherokee [at] lists
> > http://lists.octality.com/listinfo/cherokee
>
>
> _______________________________________________
> Cherokee mailing list
> Cherokee [at] lists
> http://lists.octality.com/listinfo/cherokee


_______________________________________________
Cherokee mailing list
Cherokee [at] lists
http://lists.octality.com/listinfo/cherokee

Cherokee users RSS feed   Index | Next | Previous | View Threaded
 
 


Interested in having your list archived? Contact Gossamer Threads
 
  Web Applications & Managed Hosting Powered by Gossamer Threads Inc.