Login | Register For Free | Help
Search for: (Advanced)

Mailing List Archive: Catalyst: Users

Remove Catalyst and start over?

 

 

Catalyst users RSS feed   Index | Next | Previous | View Threaded


learn.catalyst at gmail

Mar 23, 2012, 10:06 AM

Post #1 of 8 (778 views)
Permalink
Remove Catalyst and start over?

Hi,

I am new to perl and Catalyst. I am working with an Os X 10.6 system with
perl perl 5, version 12, subversion 3 (v5.12.3). I used CPAN

cpan> i
CPAN

Bundle Bundle::CPAN (ANDK/Bundle-CPAN-1.861.tar.gz)
Module = CPAN (ANDK/CPAN-1.9800.tar.gz)
2 items found

to install Catalyst::Devel in the system perl archive a few days ago.

I can't seem to start a new catalyst application and old ones that I tried
to make years ago when I first decided to try to learn Cat won't start
either. I think that I want to remove Catalyst from the system perl and
install perl locally and then cat locally.



My question is how do I remove this recent install of catalyst::devel?



Thanks so much in advance!!!
QC



Alternately I don't know what to do to make the one I just installed work

FYI

1. When I try to start a new catalyst app it says that it can't find
catalyst.pl
This is the same as root (via sudo) or in my user login

2. When I try to run an old cat app I seem to get Moose errors
LolCatalyst-Lite$ cd script/
script$ ./lolcatalyst_lite_server.pl
"load_first_existing_class" is not exported by the Class::Load module
Can't continue after import errors at
/usr/local/ActivePerl-5.12/site/lib/Moose/Util.pm line 12
BEGIN failed--compilation aborted at
/usr/local/ActivePerl-5.12/site/lib/Moose/Util.pm line 12.
Compilation failed in require at
/usr/local/ActivePerl-5.12/site/lib/Moose/Meta/Class.pm line 28.
BEGIN failed--compilation aborted at
/usr/local/ActivePerl-5.12/site/lib/Moose/Meta/Class.pm line 28.
Compilation failed in require at
/usr/local/ActivePerl-5.12/site/lib/Moose.pm line 28.
BEGIN failed--compilation aborted at
/usr/local/ActivePerl-5.12/site/lib/Moose.pm line 28.
Compilation failed in require at
/usr/local/ActivePerl-5.12/site/lib/Catalyst/Engine.pm line 3.
BEGIN failed--compilation aborted at
/usr/local/ActivePerl-5.12/site/lib/Catalyst/Engine.pm line 3.
Compilation failed in require at (eval 2) line 2.
...propagated at /usr/local/ActivePerl-5.12/lib/base.pm line 94.
BEGIN failed--compilation aborted at
/usr/local/ActivePerl-5.12/site/lib/Catalyst/Engine/HTTP.pm line 6.
Compilation failed in require at ./lolcatalyst_lite_server.pl line 6.
BEGIN failed--compilation aborted at ./lolcatalyst_lite_server.pl line 7.


davewood at gmx

Mar 23, 2012, 10:14 AM

Post #2 of 8 (753 views)
Permalink
Re: Remove Catalyst and start over? [In reply to]

run moose-outdated.

"moose-outdated is a tool that ships with Moose to help you spot
dependency problems"

On 23 March 2012 18:06, Robyn Jonahs <learn.catalyst [at] gmail> wrote:
> Hi,
>
> I am new to perl and Catalyst. I am working with an Os X 10.6 system with
> perl perl 5, version 12, subversion 3 (v5.12.3). I used CPAN
>
> cpan> i
> CPAN
> Bundle    Bundle::CPAN           (ANDK/Bundle-CPAN-1.861.tar.gz)
> Module  = CPAN                   (ANDK/CPAN-1.9800.tar.gz)
> 2 items found
>
> to install Catalyst::Devel in the system perl archive a few days ago.
>
> I can't seem to start a new catalyst application and old ones that I tried
> to make years ago when I first decided to try to learn Cat won't start
> either. I think that I want to remove Catalyst from the system perl and
> install perl locally and then cat locally.
>
>
>
> My question is how do I remove this recent install of catalyst::devel?
>
>
>
> Thanks so much in advance!!!
> QC
>
>
>
> Alternately I don't know what to do to make the one I just installed work
>
> FYI
>
> 1. When I try to start a new catalyst app it says that it can't find
> catalyst.pl
>   This is the same as root (via sudo) or in my user login
>
> 2. When I try to run an old cat app I seem to get Moose errors
> LolCatalyst-Lite$ cd script/
> script$ ./lolcatalyst_lite_server.pl
> "load_first_existing_class" is not exported by the Class::Load module
> Can't continue after import errors at
> /usr/local/ActivePerl-5.12/site/lib/Moose/Util.pm line 12
> BEGIN failed--compilation aborted at
> /usr/local/ActivePerl-5.12/site/lib/Moose/Util.pm line 12.
> Compilation failed in require at
> /usr/local/ActivePerl-5.12/site/lib/Moose/Meta/Class.pm line 28.
> BEGIN failed--compilation aborted at
> /usr/local/ActivePerl-5.12/site/lib/Moose/Meta/Class.pm line 28.
> Compilation failed in require at
> /usr/local/ActivePerl-5.12/site/lib/Moose.pm line 28.
> BEGIN failed--compilation aborted at
> /usr/local/ActivePerl-5.12/site/lib/Moose.pm line 28.
> Compilation failed in require at
> /usr/local/ActivePerl-5.12/site/lib/Catalyst/Engine.pm line 3.
> BEGIN failed--compilation aborted at
> /usr/local/ActivePerl-5.12/site/lib/Catalyst/Engine.pm line 3.
> Compilation failed in require at (eval 2) line 2.
>     ...propagated at /usr/local/ActivePerl-5.12/lib/base.pm line 94.
> BEGIN failed--compilation aborted at
> /usr/local/ActivePerl-5.12/site/lib/Catalyst/Engine/HTTP.pm line 6.
> Compilation failed in require at ./lolcatalyst_lite_server.pl line 6.
> BEGIN failed--compilation aborted at ./lolcatalyst_lite_server.pl line 7.
>
>
> _______________________________________________
> List: Catalyst [at] lists
> Listinfo: http://lists.scsys.co.uk/cgi-bin/mailman/listinfo/catalyst
> Searchable archive: http://www.mail-archive.com/catalyst [at] lists/
> Dev site: http://dev.catalyst.perl.org/
>

_______________________________________________
List: Catalyst [at] lists
Listinfo: http://lists.scsys.co.uk/cgi-bin/mailman/listinfo/catalyst
Searchable archive: http://www.mail-archive.com/catalyst [at] lists/
Dev site: http://dev.catalyst.perl.org/


learn.catalyst at gmail

Mar 23, 2012, 11:02 AM

Post #3 of 8 (757 views)
Permalink
Re: Remove Catalyst and start over? [In reply to]

Thanks. I saw that before and was not sure what to do with the tip. When I
tried this a few days ago, it did not seem that moose-outdated.pl was on my
machine.

So after you said it again, I looked into it more. I got the script
http://cpansearch.perl.org/src/DOY/Moose-2.0002/bin/moose-outdated and put
it in a local directory. I ran it both as my local user and sudo and both
returned nothing....

moose$ perl ./moose-outdated.pl
moose$ sudo sh
Password:
moose$ perl ./moose-outdated.pl
moose$



Also cpan seems to say Moose is all updated

Moose::.*
...
All modules are up to date for Moose::.*


Does that mean that I am doing it wrong or that Moose is all set?






On Fri, Mar 23, 2012 at 1:14 PM, David Schmidt <davewood [at] gmx> wrote:

> run moose-outdated.
>
> "moose-outdated is a tool that ships with Moose to help you spot
> dependency problems"
>
> On 23 March 2012 18:06, Robyn Jonahs <learn.catalyst [at] gmail> wrote:
> > Hi,
> >
> > I am new to perl and Catalyst. I am working with an Os X 10.6 system with
> > perl perl 5, version 12, subversion 3 (v5.12.3). I used CPAN
> >
> > cpan> i
> > CPAN
> > Bundle Bundle::CPAN (ANDK/Bundle-CPAN-1.861.tar.gz)
> > Module = CPAN (ANDK/CPAN-1.9800.tar.gz)
> > 2 items found
> >
> > to install Catalyst::Devel in the system perl archive a few days ago.
> >
> > I can't seem to start a new catalyst application and old ones that I
> tried
> > to make years ago when I first decided to try to learn Cat won't start
> > either. I think that I want to remove Catalyst from the system perl and
> > install perl locally and then cat locally.
> >
> >
> >
> > My question is how do I remove this recent install of catalyst::devel?
> >
> >
> >
> > Thanks so much in advance!!!
> > QC
> >
> >
> >
> > Alternately I don't know what to do to make the one I just installed work
> >
> > FYI
> >
> > 1. When I try to start a new catalyst app it says that it can't find
> > catalyst.pl
> > This is the same as root (via sudo) or in my user login
> >
> > 2. When I try to run an old cat app I seem to get Moose errors
> > LolCatalyst-Lite$ cd script/
> > script$ ./lolcatalyst_lite_server.pl
> > "load_first_existing_class" is not exported by the Class::Load module
> > Can't continue after import errors at
> > /usr/local/ActivePerl-5.12/site/lib/Moose/Util.pm line 12
> > BEGIN failed--compilation aborted at
> > /usr/local/ActivePerl-5.12/site/lib/Moose/Util.pm line 12.
> > Compilation failed in require at
> > /usr/local/ActivePerl-5.12/site/lib/Moose/Meta/Class.pm line 28.
> > BEGIN failed--compilation aborted at
> > /usr/local/ActivePerl-5.12/site/lib/Moose/Meta/Class.pm line 28.
> > Compilation failed in require at
> > /usr/local/ActivePerl-5.12/site/lib/Moose.pm line 28.
> > BEGIN failed--compilation aborted at
> > /usr/local/ActivePerl-5.12/site/lib/Moose.pm line 28.
> > Compilation failed in require at
> > /usr/local/ActivePerl-5.12/site/lib/Catalyst/Engine.pm line 3.
> > BEGIN failed--compilation aborted at
> > /usr/local/ActivePerl-5.12/site/lib/Catalyst/Engine.pm line 3.
> > Compilation failed in require at (eval 2) line 2.
> > ...propagated at /usr/local/ActivePerl-5.12/lib/base.pm line 94.
> > BEGIN failed--compilation aborted at
> > /usr/local/ActivePerl-5.12/site/lib/Catalyst/Engine/HTTP.pm line 6.
> > Compilation failed in require at ./lolcatalyst_lite_server.pl line 6.
> > BEGIN failed--compilation aborted at ./lolcatalyst_lite_server.pl line
> 7.
> >
> >
> > _______________________________________________
> > List: Catalyst [at] lists
> > Listinfo: http://lists.scsys.co.uk/cgi-bin/mailman/listinfo/catalyst
> > Searchable archive:
> http://www.mail-archive.com/catalyst [at] lists/
> > Dev site: http://dev.catalyst.perl.org/
> >
>
> _______________________________________________
> List: Catalyst [at] lists
> Listinfo: http://lists.scsys.co.uk/cgi-bin/mailman/listinfo/catalyst
> Searchable archive:
> http://www.mail-archive.com/catalyst [at] lists/
> Dev site: http://dev.catalyst.perl.org/
>


mdietrich at cpan

Mar 23, 2012, 11:25 AM

Post #4 of 8 (749 views)
Permalink
Re: Remove Catalyst and start over? [In reply to]

Hi,

Am 23.03.2012 um 19:02 schrieb Robyn Jonahs:

> cpan> upgrade Moose::.*

try: `upgrade Moose` inside of the CPAN shell.

Instead of using CPAN.pm I recommend using cpanm. Install it by copypasting this into your terminal:

curl -L http://cpanmin.us | perl - --sudo App::cpanminus

Then run `cpanm Moose` (prepend "sudo" if you need). It's easier and much faster :-).

And because you're new to Perl: don't copy scripts from a module release, install the module instead and use the scripts afterwards (except you know what you're doing).

Best,
Matthias

--
rainboxx Software Engineering
Matthias Dietrich

rainboxx Matthias Dietrich | Phone: +49 7141 / 2 39 14 71
Knigsallee 43 | Mobil: +49 151 / 50 60 78 64
71638 Ludwigsburg | WWW : http://www.rainboxx.de


learn.catalyst at gmail

Mar 23, 2012, 11:52 AM

Post #5 of 8 (752 views)
Permalink
Re: Remove Catalyst and start over? [In reply to]

On Fri, Mar 23, 2012 at 2:25 PM, Matthias Dietrich <mdietrich [at] cpan>wrote:

> Hi,
>
> Am 23.03.2012 um 19:02 schrieb Robyn Jonahs:
>
> cpan> upgrade Moose::.*
>
>
> try: `upgrade Moose` inside of the CPAN shell.
>
> Instead of using CPAN.pm I recommend using cpanm. Install it by
> copypasting this into your terminal:
>
> curl -L http://cpanmin.us | perl - --sudo App::cpanminus
>
> Then run `cpanm Moose` (prepend "sudo" if you need). It's easier and much
> faster :-).
>
> And because you're new to Perl: don't copy scripts from a module release,
> install the module instead and use the scripts afterwards (except you know
> what you're doing).
>
> Best,
> Matthias
>
> --
> rainboxx Software Engineering
> Matthias Dietrich
>
> rainboxx Matthias Dietrich | Phone: +49 7141 / 2 39 14 71
> Knigsallee 43 | Mobil: +49 151 / 50 60 78 64
> 71638 Ludwigsburg | WWW : http://www.rainboxx.de
>
>
>
>
>
> _______________________________________________
> List: Catalyst [at] lists
> Listinfo: http://lists.scsys.co.uk/cgi-bin/mailman/listinfo/catalyst
> Searchable archive:
> http://www.mail-archive.com/catalyst [at] lists/
> Dev site: http://dev.catalyst.perl.org/
>
>

Thanks guys.

CPAN and cpanm both say that Moose is up to date.

cpanm Moose
Moose is up to date. (2.0402)

I also found the location of the catalyst.pl script and made sure that my
PATH saw it. This fixed the problem where I could not call catalyst.pl from
the command line. However I still get these errors when I try to create a
new Catalyst App...

test$ catalyst.pl MyApp
"load_first_existing_class" is not exported by the Class::Load module
Can't continue after import errors at
/usr/local/ActivePerl-5.12/site/lib/Moose/Util.pm line 12
BEGIN failed--compilation aborted at
/usr/local/ActivePerl-5.12/site/lib/Moose/Util.pm line 12.
Compilation failed in require at
/usr/local/ActivePerl-5.12/site/lib/Moose/Meta/Class.pm line 28.
BEGIN failed--compilation aborted at
/usr/local/ActivePerl-5.12/site/lib/Moose/Meta/Class.pm line 28.
Compilation failed in require at
/usr/local/ActivePerl-5.12/site/lib/Moose.pm line 28.
BEGIN failed--compilation aborted at
/usr/local/ActivePerl-5.12/site/lib/Moose.pm line 28.
Compilation failed in require at
/usr/local/ActivePerl-5.12/site/lib/Catalyst/Helper.pm line 2.
BEGIN failed--compilation aborted at
/usr/local/ActivePerl-5.12/site/lib/Catalyst/Helper.pm line 2.
Compilation failed in require at /usr/local/ActivePerl-5.12/site/bin/
catalyst.pl line 26.
BEGIN failed--compilation aborted at /usr/local/ActivePerl-5.12/site/bin/
catalyst.pl line 26.
test$


Any ideas? Is this a path that I am missing to some Moose resource rather
than part of Moose?

temp$ echo $PATH
/usr/local/ActivePerl-5.12/bin:/usr/local/mysql/bin:/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin:/usr/local/git/bin:/usr/texbin:/usr/X11/bin


Thanks again for all the help.


learn.catalyst at gmail

Mar 23, 2012, 3:12 PM

Post #6 of 8 (753 views)
Permalink
Re: Remove Catalyst and start over? [In reply to]

So Moose said that it was all updated yet it did not have the command line
file moose-outdated until I ran the cpanm Moose command (sudo if required)
Also, following the Moose intro in the "Definitive Guide to Catalyst" I did
not have module-starter until I ran cpanm Module::Starter. But I still get
the same error

CrashCOurse-Point$ perl -Ilib t/00-load.t
not ok 1 - use CrashCOurse::Point;
# Failed test 'use CrashCOurse::Point;'
# at t/00-load.t line 6.
# Tried to use 'CrashCOurse::Point'.
# Error: "load_first_existing_class" is not exported by the
Class::Load module
# Can't continue after import errors at
/usr/local/ActivePerl-5.12/site/lib/Moose/Util.pm line 12
# BEGIN failed--compilation aborted at
/usr/local/ActivePerl-5.12/site/lib/Moose/Util.pm line 12.
# Compilation failed in require at
/usr/local/ActivePerl-5.12/site/lib/Moose/Meta/Class.pm line 28.
# BEGIN failed--compilation aborted at
/usr/local/ActivePerl-5.12/site/lib/Moose/Meta/Class.pm line 28.
# Compilation failed in require at
/usr/local/ActivePerl-5.12/site/lib/Moose.pm line 28.
# BEGIN failed--compilation aborted at
/usr/local/ActivePerl-5.12/site/lib/Moose.pm line 28.
# Compilation failed in require at lib/CrashCOurse/Point.pm line 2.
# BEGIN failed--compilation aborted at lib/CrashCOurse/Point.pm line 2.
# Compilation failed in require at (eval 4) line 2.
# BEGIN failed--compilation aborted at (eval 4) line 2.
Bail out!
# Testing CrashCOurse::Point , Perl 5.012003, perl
Can't locate object method "new" via package "CrashCOurse::Point" at
t/00-load.t line 11.
1..1
# Looks like you failed 1 test of 1.
# Looks like your test exited with 255 just after 1.

I am out of ideas for where to find the problem.


On Fri, Mar 23, 2012 at 2:52 PM, Robyn Jonahs <learn.catalyst [at] gmail>wrote:

> On Fri, Mar 23, 2012 at 2:25 PM, Matthias Dietrich <mdietrich [at] cpan>wrote:
>
>> Hi,
>>
>> Am 23.03.2012 um 19:02 schrieb Robyn Jonahs:
>>
>> cpan> upgrade Moose::.*
>>
>>
>> try: `upgrade Moose` inside of the CPAN shell.
>>
>> Instead of using CPAN.pm I recommend using cpanm. Install it by
>> copypasting this into your terminal:
>>
>> curl -L http://cpanmin.us | perl - --sudo App::cpanminus
>>
>> Then run `cpanm Moose` (prepend "sudo" if you need). It's easier and
>> much faster :-).
>>
>> And because you're new to Perl: don't copy scripts from a module release,
>> install the module instead and use the scripts afterwards (except you know
>> what you're doing).
>>
>> Best,
>> Matthias
>>
>> --
>> rainboxx Software Engineering
>> Matthias Dietrich
>>
>> rainboxx Matthias Dietrich | Phone: +49 7141 / 2 39 14 71
>> Knigsallee 43 | Mobil: +49 151 / 50 60 78 64
>> 71638 Ludwigsburg | WWW : http://www.rainboxx.de
>>
>>
>>
>>
>>
>> _______________________________________________
>> List: Catalyst [at] lists
>> Listinfo: http://lists.scsys.co.uk/cgi-bin/mailman/listinfo/catalyst
>> Searchable archive:
>> http://www.mail-archive.com/catalyst [at] lists/
>> Dev site: http://dev.catalyst.perl.org/
>>
>>
>
> Thanks guys.
>
> CPAN and cpanm both say that Moose is up to date.
>
> cpanm Moose
> Moose is up to date. (2.0402)
>
> I also found the location of the catalyst.pl script and made sure that my
> PATH saw it. This fixed the problem where I could not call catalyst.plfrom the command line. However I still get these errors when I try to
> create a new Catalyst App...
>
> test$ catalyst.pl MyApp
>
> "load_first_existing_class" is not exported by the Class::Load module
> Can't continue after import errors at
> /usr/local/ActivePerl-5.12/site/lib/Moose/Util.pm line 12
> BEGIN failed--compilation aborted at
> /usr/local/ActivePerl-5.12/site/lib/Moose/Util.pm line 12.
> Compilation failed in require at
> /usr/local/ActivePerl-5.12/site/lib/Moose/Meta/Class.pm line 28.
> BEGIN failed--compilation aborted at
> /usr/local/ActivePerl-5.12/site/lib/Moose/Meta/Class.pm line 28.
> Compilation failed in require at
> /usr/local/ActivePerl-5.12/site/lib/Moose.pm line 28.
> BEGIN failed--compilation aborted at
> /usr/local/ActivePerl-5.12/site/lib/Moose.pm line 28.
> Compilation failed in require at
> /usr/local/ActivePerl-5.12/site/lib/Catalyst/Helper.pm line 2.
> BEGIN failed--compilation aborted at
> /usr/local/ActivePerl-5.12/site/lib/Catalyst/Helper.pm line 2.
> Compilation failed in require at /usr/local/ActivePerl-5.12/site/bin/
> catalyst.pl line 26.
> BEGIN failed--compilation aborted at /usr/local/ActivePerl-5.12/site/bin/
> catalyst.pl line 26.
> test$
>
>
> Any ideas? Is this a path that I am missing to some Moose resource rather
> than part of Moose?
>
> temp$ echo $PATH
>
> /usr/local/ActivePerl-5.12/bin:/usr/local/mysql/bin:/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin:/usr/local/git/bin:/usr/texbin:/usr/X11/bin
>
>
> Thanks again for all the help.
>


mdietrich at cpan

Mar 23, 2012, 4:03 PM

Post #7 of 8 (754 views)
Permalink
Re: Remove Catalyst and start over? [In reply to]

Sorry for top posting - iPhone^^.

Robyn, just something I've noticed: is there a reason that you're using an ActivePerl instead the system Perl (or one brewed with perlbrew)?

I think some other modules are out of date, too. You could update all your modules, if you don't have to rely on some specific versions (see cpanm docs, cannot search for the correct command atm), or try to update one by one (here: update Class::Load).

Just my thoughts.

Matthias

--

Sent from my iPhone so expect spelling errors and stuff.

rainboxx Matthias Dietrich
Freelance Software Engineer

rainboxx
Königsallee 43
71638 Ludwigsburg
+4915150607864

Vist: http://www.rainboxx.de

Am 23.03.2012 um 23:12 schrieb Robyn Jonahs <learn.catalyst [at] gmail>:

> So Moose said that it was all updated yet it did not have the command line file moose-outdated until I ran the cpanm Moose command (sudo if required) Also, following the Moose intro in the "Definitive Guide to Catalyst" I did not have module-starter until I ran cpanm Module::Starter. But I still get the same error
>
> CrashCOurse-Point$ perl -Ilib t/00-load.t
> not ok 1 - use CrashCOurse::Point;
> # Failed test 'use CrashCOurse::Point;'
> # at t/00-load.t line 6.
> # Tried to use 'CrashCOurse::Point'.
> # Error: "load_first_existing_class" is not exported by the Class::Load module
> # Can't continue after import errors at /usr/local/ActivePerl-5.12/site/lib/Moose/Util.pm line 12
> # BEGIN failed--compilation aborted at /usr/local/ActivePerl-5.12/site/lib/Moose/Util.pm line 12.
> # Compilation failed in require at /usr/local/ActivePerl-5.12/site/lib/Moose/Meta/Class.pm line 28.
> # BEGIN failed--compilation aborted at /usr/local/ActivePerl-5.12/site/lib/Moose/Meta/Class.pm line 28.
> # Compilation failed in require at /usr/local/ActivePerl-5.12/site/lib/Moose.pm line 28.
> # BEGIN failed--compilation aborted at /usr/local/ActivePerl-5.12/site/lib/Moose.pm line 28.
> # Compilation failed in require at lib/CrashCOurse/Point.pm line 2.
> # BEGIN failed--compilation aborted at lib/CrashCOurse/Point.pm line 2.
> # Compilation failed in require at (eval 4) line 2.
> # BEGIN failed--compilation aborted at (eval 4) line 2.
> Bail out!
> # Testing CrashCOurse::Point , Perl 5.012003, perl
> Can't locate object method "new" via package "CrashCOurse::Point" at t/00-load.t line 11.
> 1..1
> # Looks like you failed 1 test of 1.
> # Looks like your test exited with 255 just after 1.
>
> I am out of ideas for where to find the problem.
>
>
> On Fri, Mar 23, 2012 at 2:52 PM, Robyn Jonahs <learn.catalyst [at] gmail> wrote:
> On Fri, Mar 23, 2012 at 2:25 PM, Matthias Dietrich <mdietrich [at] cpan> wrote:
> Hi,
>
> Am 23.03.2012 um 19:02 schrieb Robyn Jonahs:
>
>> cpan> upgrade Moose::.*
>
> try: `upgrade Moose` inside of the CPAN shell.
>
> Instead of using CPAN.pm I recommend using cpanm. Install it by copypasting this into your terminal:
>
> curl -L http://cpanmin.us | perl - --sudo App::cpanminus
>
> Then run `cpanm Moose` (prepend "sudo" if you need). It's easier and much faster :-).
>
> And because you're new to Perl: don't copy scripts from a module release, install the module instead and use the scripts afterwards (except you know what you're doing).
>
> Best,
> Matthias
>
> --
> rainboxx Software Engineering
> Matthias Dietrich
>
> rainboxx Matthias Dietrich | Phone: +49 7141 / 2 39 14 71
> Königsallee 43 | Mobil: +49 151 / 50 60 78 64
> 71638 Ludwigsburg | WWW : http://www.rainboxx.de
>
>
>
>
>
> _______________________________________________
> List: Catalyst [at] lists
> Listinfo: http://lists.scsys.co.uk/cgi-bin/mailman/listinfo/catalyst
> Searchable archive: http://www.mail-archive.com/catalyst [at] lists/
> Dev site: http://dev.catalyst.perl.org/
>
>
>
> Thanks guys.
>
> CPAN and cpanm both say that Moose is up to date.
>
> cpanm Moose
> Moose is up to date. (2.0402)
>
> I also found the location of the catalyst.pl script and made sure that my PATH saw it. This fixed the problem where I could not call catalyst.pl from the command line. However I still get these errors when I try to create a new Catalyst App...
>
> test$ catalyst.pl MyApp
>
> "load_first_existing_class" is not exported by the Class::Load module
> Can't continue after import errors at /usr/local/ActivePerl-5.12/site/lib/Moose/Util.pm line 12
> BEGIN failed--compilation aborted at /usr/local/ActivePerl-5.12/site/lib/Moose/Util.pm line 12.
> Compilation failed in require at /usr/local/ActivePerl-5.12/site/lib/Moose/Meta/Class.pm line 28.
> BEGIN failed--compilation aborted at /usr/local/ActivePerl-5.12/site/lib/Moose/Meta/Class.pm line 28.
> Compilation failed in require at /usr/local/ActivePerl-5.12/site/lib/Moose.pm line 28.
> BEGIN failed--compilation aborted at /usr/local/ActivePerl-5.12/site/lib/Moose.pm line 28.
> Compilation failed in require at /usr/local/ActivePerl-5.12/site/lib/Catalyst/Helper.pm line 2.
> BEGIN failed--compilation aborted at /usr/local/ActivePerl-5.12/site/lib/Catalyst/Helper.pm line 2.
> Compilation failed in require at /usr/local/ActivePerl-5.12/site/bin/catalyst.pl line 26.
> BEGIN failed--compilation aborted at /usr/local/ActivePerl-5.12/site/bin/catalyst.pl line 26.
> test$
>
>
> Any ideas? Is this a path that I am missing to some Moose resource rather than part of Moose?
>
> temp$ echo $PATH
> /usr/local/ActivePerl-5.12/bin:/usr/local/mysql/bin:/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin:/usr/local/git/bin:/usr/texbin:/usr/X11/bin
>
>
> Thanks again for all the help.
>
> _______________________________________________
> List: Catalyst [at] lists
> Listinfo: http://lists.scsys.co.uk/cgi-bin/mailman/listinfo/catalyst
> Searchable archive: http://www.mail-archive.com/catalyst [at] lists/
> Dev site: http://dev.catalyst.perl.org/


learn.catalyst at gmail

Mar 23, 2012, 11:51 PM

Post #8 of 8 (754 views)
Permalink
Re: Remove Catalyst and start over? [In reply to]

Hi Matthias,

Thanks for the comments. The problem has been resolved.

I removed the .bashrc pointers to the ActivePerl and then installed
perlbrew with what I think was the system perl, I had two other versions.
FYI I was using active perl since for a perl NOOB, the perl web page said
it was an easy pre-configured way to upgrade to new perl versions... plus I
was away from a fast, stable internet connection at the time of the
installation to 5.12.

I used active perl to make a local installation of perl 5.14.2 and set up
all the mcpan and such and installed Catalyst::Devel from cpanm. It works
now for creating a new Cat app and for the app that I started when working
through the "Definitive Guide to Catalyst" a few years ago and not getting
out of Chapter 3 at that time.

I hope that this is clear enough to help with other problems with
installing and moose problems. moose-outdated was appeared for me as I said
after getting cpanm and doing cpanm Moose.

Thanks everyone, off to play with Catalyst.




On Fri, Mar 23, 2012 at 7:03 PM, Matthias Dietrich <mdietrich [at] cpan>wrote:

> Sorry for top posting - iPhone^^.
>
> Robyn, just something I've noticed: is there a reason that you're using an
> ActivePerl instead the system Perl (or one brewed with perlbrew)?
>
> I think some other modules are out of date, too. You could update all your
> modules, if you don't have to rely on some specific versions (see cpanm
> docs, cannot search for the correct command atm), or try to update one by
> one (here: update Class::Load).
>
> Just my thoughts.
>
> Matthias
>
> --
>
> Sent from my iPhone so expect spelling errors and stuff.
>
> rainboxx Matthias Dietrich
> Freelance Software Engineer
>
> rainboxx
> Knigsallee 43
> 71638 Ludwigsburg
> +4915150607864
>
> Vist: http://www.rainboxx.de
>
> Am 23.03.2012 um 23:12 schrieb Robyn Jonahs <learn.catalyst [at] gmail>:
>
> So Moose said that it was all updated yet it did not have the command line
> file moose-outdated until I ran the cpanm Moose command (sudo if required)
> Also, following the Moose intro in the "Definitive Guide to Catalyst" I did
> not have module-starter until I ran cpanm Module::Starter. But I still get
> the same error
>
> CrashCOurse-Point$ perl -Ilib t/00-load.t
> not ok 1 - use CrashCOurse::Point;
> # Failed test 'use CrashCOurse::Point;'
> # at t/00-load.t line 6.
> # Tried to use 'CrashCOurse::Point'.
> # Error: "load_first_existing_class" is not exported by the
> Class::Load module
> # Can't continue after import errors at
> /usr/local/ActivePerl-5.12/site/lib/Moose/Util.pm line 12
> # BEGIN failed--compilation aborted at
> /usr/local/ActivePerl-5.12/site/lib/Moose/Util.pm line 12.
> # Compilation failed in require at
> /usr/local/ActivePerl-5.12/site/lib/Moose/Meta/Class.pm line 28.
> # BEGIN failed--compilation aborted at
> /usr/local/ActivePerl-5.12/site/lib/Moose/Meta/Class.pm line 28.
> # Compilation failed in require at
> /usr/local/ActivePerl-5.12/site/lib/Moose.pm line 28.
> # BEGIN failed--compilation aborted at
> /usr/local/ActivePerl-5.12/site/lib/Moose.pm line 28.
> # Compilation failed in require at lib/CrashCOurse/Point.pm line 2.
> # BEGIN failed--compilation aborted at lib/CrashCOurse/Point.pm line 2.
> # Compilation failed in require at (eval 4) line 2.
> # BEGIN failed--compilation aborted at (eval 4) line 2.
> Bail out!
> # Testing CrashCOurse::Point , Perl 5.012003, perl
> Can't locate object method "new" via package "CrashCOurse::Point" at
> t/00-load.t line 11.
> 1..1
> # Looks like you failed 1 test of 1.
> # Looks like your test exited with 255 just after 1.
>
> I am out of ideas for where to find the problem.
>
>
> On Fri, Mar 23, 2012 at 2:52 PM, Robyn Jonahs <learn.catalyst [at] gmail>wrote:
>
>> On Fri, Mar 23, 2012 at 2:25 PM, Matthias Dietrich <mdietrich [at] cpan>wrote:
>>
>>> Hi,
>>>
>>> Am 23.03.2012 um 19:02 schrieb Robyn Jonahs:
>>>
>>> cpan> upgrade Moose::.*
>>>
>>>
>>> try: `upgrade Moose` inside of the CPAN shell.
>>>
>>> Instead of using CPAN.pm I recommend using cpanm. Install it by
>>> copypasting this into your terminal:
>>>
>>> curl -L http://cpanmin.us | perl - --sudo App::cpanminus
>>>
>>> Then run `cpanm Moose` (prepend "sudo" if you need). It's easier and
>>> much faster :-).
>>>
>>> And because you're new to Perl: don't copy scripts from a module
>>> release, install the module instead and use the scripts afterwards (except
>>> you know what you're doing).
>>>
>>> Best,
>>> Matthias
>>>
>>> --
>>> rainboxx Software Engineering
>>> Matthias Dietrich
>>>
>>> rainboxx Matthias Dietrich | Phone: +49 7141 / 2 39 14 71
>>> Knigsallee 43 | Mobil: +49 151 / 50 60 78 64
>>> 71638 Ludwigsburg | WWW : http://www.rainboxx.de
>>>
>>>
>>>
>>>
>>>
>>> _______________________________________________
>>> List: Catalyst [at] lists
>>> Listinfo: http://lists.scsys.co.uk/cgi-bin/mailman/listinfo/catalyst
>>> Searchable archive:
>>> http://www.mail-archive.com/catalyst [at] lists/
>>> Dev site: http://dev.catalyst.perl.org/
>>>
>>>
>>
>> Thanks guys.
>>
>> CPAN and cpanm both say that Moose is up to date.
>>
>> cpanm Moose
>> Moose is up to date. (2.0402)
>>
>> I also found the location of the catalyst.pl script and made sure that
>> my PATH saw it. This fixed the problem where I could not call catalyst.plfrom the command line. However I still get these errors when I try to
>> create a new Catalyst App...
>>
>> test$ catalyst.pl MyApp
>>
>> "load_first_existing_class" is not exported by the Class::Load module
>> Can't continue after import errors at
>> /usr/local/ActivePerl-5.12/site/lib/Moose/Util.pm line 12
>> BEGIN failed--compilation aborted at
>> /usr/local/ActivePerl-5.12/site/lib/Moose/Util.pm line 12.
>> Compilation failed in require at
>> /usr/local/ActivePerl-5.12/site/lib/Moose/Meta/Class.pm line 28.
>> BEGIN failed--compilation aborted at
>> /usr/local/ActivePerl-5.12/site/lib/Moose/Meta/Class.pm line 28.
>> Compilation failed in require at
>> /usr/local/ActivePerl-5.12/site/lib/Moose.pm line 28.
>> BEGIN failed--compilation aborted at
>> /usr/local/ActivePerl-5.12/site/lib/Moose.pm line 28.
>> Compilation failed in require at
>> /usr/local/ActivePerl-5.12/site/lib/Catalyst/Helper.pm line 2.
>> BEGIN failed--compilation aborted at
>> /usr/local/ActivePerl-5.12/site/lib/Catalyst/Helper.pm line 2.
>> Compilation failed in require at /usr/local/ActivePerl-5.12/site/bin/
>> catalyst.pl line 26.
>> BEGIN failed--compilation aborted at /usr/local/ActivePerl-5.12/site/bin/
>> catalyst.pl line 26.
>> test$
>>
>>
>> Any ideas? Is this a path that I am missing to some Moose resource
>> rather than part of Moose?
>>
>> temp$ echo $PATH
>>
>> /usr/local/ActivePerl-5.12/bin:/usr/local/mysql/bin:/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin:/usr/local/git/bin:/usr/texbin:/usr/X11/bin
>>
>>
>> Thanks again for all the help.
>>
>
> _______________________________________________
> List: Catalyst [at] lists
> Listinfo: http://lists.scsys.co.uk/cgi-bin/mailman/listinfo/catalyst
> Searchable archive:
> http://www.mail-archive.com/catalyst [at] lists/
> Dev site: http://dev.catalyst.perl.org/
>
>
> _______________________________________________
> List: Catalyst [at] lists
> Listinfo: http://lists.scsys.co.uk/cgi-bin/mailman/listinfo/catalyst
> Searchable archive:
> http://www.mail-archive.com/catalyst [at] lists/
> Dev site: http://dev.catalyst.perl.org/
>
>

Catalyst users RSS feed   Index | Next | Previous | View Threaded
 
 


Interested in having your list archived? Contact Gossamer Threads
 
  Web Applications & Managed Hosting Powered by Gossamer Threads Inc.