Login | Register For Free | Help
Search for: (Advanced)

Mailing List Archive: Bricolage: users

Re: Media Type already in use when no media types present

 

 

Bricolage users RSS feed   Index | Next | Previous | View Threaded


catalyst at mikeraynham

May 26, 2011, 7:50 AM

Post #1 of 2 (484 views)
Permalink
Re: Media Type already in use when no media types present

Deleting items from the GUI just deactivates them in the database.
Unfortunately, I don't think there's a way to reactivate Media Types
from the GUI. However, you can reactivate them directly from the database:

To view deleted (deactivated) media types:
SELECT * FROM media_type WHERE NOT active;

To reactivate all deleted media types:
UPDATE media_type SET active = true WHERE NOT active;

Or for a specific media type:
UPDATE media_type SET active = true WHERE name="application/pdf"


Regards,

Mike

On 26/05/11 15:32, Ian Gibbs wrote:
> Dear all,
>
> I deleted all the existing media types. Searching now returns "No Media
> Types were found". When I try to add image/jpeg or text/plain as a new
> media type, I get the message "The name "image/jpeg" is already used by
> another Media Type." If try to add "invented/mimetype" (not one that was
> in the list previously), it is accepted. If I then delete it and try to
> recreate it, I am again told it is in use. It seems like deleting a
> media type doesn't really delete it.
>
> Can anyone help, please?
>
> Ian Gibbs


ian at flash

May 27, 2011, 2:32 AM

Post #2 of 2 (429 views)
Permalink
Re: Media Type already in use when no media types present [In reply to]

On 05/26/2011 03:50 PM, Mike Raynham wrote:
> Deleting items from the GUI just deactivates them in the database. Unfortunately, I don't think
> there's a way to reactivate Media Types from the GUI. However, you can reactivate them directly from
> the database:
>
> To view deleted (deactivated) media types:
> SELECT * FROM media_type WHERE NOT active;
>
> To reactivate all deleted media types:
> UPDATE media_type SET active = true WHERE NOT active;
>
> Or for a specific media type:
> UPDATE media_type SET active = true WHERE name="application/pdf"
>
>
> Regards,
>
> Mike
>
> On 26/05/11 15:32, Ian Gibbs wrote:
>> Dear all,
>>
>> I deleted all the existing media types. Searching now returns "No Media
>> Types were found". When I try to add image/jpeg or text/plain as a new
>> media type, I get the message "The name "image/jpeg" is already used by
>> another Media Type." If try to add "invented/mimetype" (not one that was
>> in the list previously), it is accepted. If I then delete it and try to
>> recreate it, I am again told it is in use. It seems like deleting a
>> media type doesn't really delete it.
>>
>> Can anyone help, please?
>>
>> Ian Gibbs
>

Thanks Mike.

Single quotes were required, rather than double:

UPDATE media_type SET active = true WHERE name='application/pdf'

but otherwise this did work around the issue. Unfortunately it wasn't the cause of my problem (see
separate email).

Ian

Bricolage users RSS feed   Index | Next | Previous | View Threaded
 
 


Interested in having your list archived? Contact Gossamer Threads
 
  Web Applications & Managed Hosting Powered by Gossamer Threads Inc.