Login | Register For Free | Help
Search for: (Advanced)

Mailing List Archive: Bricolage: bugs
[Bricolage #237] media_uri entry disappears when media is deactivated
 

Index | Next | Previous | View Flat


no-reply at lighthouseapp

Jul 14, 2011, 8:49 AM


Views: 702
Permalink
[Bricolage #237] media_uri entry disappears when media is deactivated

// Add your reply above here
==================================================
Nick Legg updated this ticket at July 14th, 2011 @ 03:49 PM

Well, I think I have figured out why this happens. See the function _delete_uris() in lib/Bric/Biz/Asset/Business.pm. It deletes the media_uri or story_uri entry for an asset as it is deactivated.

This doesn't hurt when searching for deactivated stories, because stories have the primary_uri field in the story table itself. Media, on the other hand, do not. Once the media_uri entry is gone, you need to search for deactivated media using other methods.

Is there some benefit to deleting the media/story_uri entries? Would it hurt to _not_ do this?
--------------------------------------------------------------------------------

Assigned: theory
State: new
Milestone: 2.1.0
View this ticket online: http://bricolage.lighthouseapp.com/projects/29601/tickets/237-media_uri-entry-disappears-when-media-is-deactivated

Stop being notified of this ticket's changes: http://bricolage.lighthouseapp.com/watching/27c48405f46a503d354be705a0f7436bf52367db
Update your Profile: http://bricolage.lighthouseapp.com/profile
Support: support [at] lighthouseapp or http://help.lighthouseapp.com

Subject User Time
[Bricolage #237] media_uri entry disappears when media is deactivated no-reply at lighthouseapp Jul 14, 2011, 8:49 AM
    [Bricolage #237] media_uri entry disappears when media is deactivated no-reply at lighthouseapp Jul 14, 2011, 9:04 AM

  Index | Next | Previous | View Flat
 
 


Interested in having your list archived? Contact Gossamer Threads
 
  Web Applications & Managed Hosting Powered by Gossamer Threads Inc.