Login | Register For Free | Help
Search for: (Advanced)

Mailing List Archive: atrpms: devel

Alsa 1.0.25 EL6 needs rebuilding with sequencer support like 1.0.24 series/native alsa

 

 

atrpms devel RSS feed   Index | Next | Previous | View Threaded


lemonzest at gmail

Mar 10, 2012, 11:55 AM

Post #1 of 9 (1122 views)
Permalink
Alsa 1.0.25 EL6 needs rebuilding with sequencer support like 1.0.24 series/native alsa

Hiya

I've tracked down why i cant get midi working with your alsa 1.0.25
kmdl's, they are not build with sequencer support, whilst the 1.0.24
series and the native EL6 kernel alsa are. so this is a request for a
rebuild, thanks.

Simon Putt


_______________________________________________
atrpms-devel mailing list
atrpms-devel [at] atrpms
http://lists.atrpms.net/mailman/listinfo/atrpms-devel


Axel.Thimm at ATrpms

Mar 10, 2012, 12:56 PM

Post #2 of 9 (1079 views)
Permalink
Re: Alsa 1.0.25 EL6 needs rebuilding with sequencer support like 1.0.24 series/native alsa [In reply to]

Hi,

On Sat, Mar 10, 2012 at 07:55:25PM +0000, Simon Putt wrote:
> Hiya
>
> I've tracked down why i cant get midi working with your alsa 1.0.25
> kmdl's, they are not build with sequencer support, whilst the 1.0.24
> series and the native EL6 kernel alsa are. so this is a request for a
> rebuild, thanks.
>
> Simon Putt

which kmdls are these? I checked for example
alsa-driver-kmdl-2.6.32-220.el6.x86_64-1.0.25-94.el6.x86_64.rpm and
the option --with-sequencer=yes is passed and the build responds with

[...]
checking for sequencer support... yes
[...]

But maybe something is broken with the sequencer in 1.0.25. There were
some changes, maybe they affect your midi app?
http://alsa-project.org/main/index.php/Changes_v1.0.24_v1.0.25#ALSA_sequencer
--
Axel.Thimm at ATrpms.net

_______________________________________________
atrpms-devel mailing list
atrpms-devel [at] atrpms
http://lists.atrpms.net/mailman/listinfo/atrpms-devel


lemonzest at gmail

Mar 10, 2012, 1:57 PM

Post #3 of 9 (1096 views)
Permalink
Re: Alsa 1.0.25 EL6 needs rebuilding with sequencer support like 1.0.24 series/native alsa [In reply to]

Yeah I compared the two rpms together and a number of .ko files are
missing, like snd-midi and snd-opl3-synth which i need.

any app which scans for midi devices makes dmesg spew this

snd_seq_midi: disagrees about version of symbol snd_rawmidi_info_select
snd_seq_midi: Unknown symbol snd_rawmidi_info_select
snd_seq_midi: disagrees about version of symbol
snd_rawmidi_output_params
snd_seq_midi: Unknown symbol snd_rawmidi_output_params
snd_seq_midi: disagrees about version of symbol snd_rawmidi_kernel_read
snd_seq_midi: Unknown symbol snd_rawmidi_kernel_read
snd_seq_midi: disagrees about version of symbol
snd_seq_device_register_driver
snd_seq_midi: Unknown symbol snd_seq_device_register_driver
snd_seq_midi: disagrees about version of symbol snd_rawmidi_kernel_write
snd_seq_midi: Unknown symbol snd_rawmidi_kernel_write
snd_seq_midi: disagrees about version of symbol snd_rawmidi_drain_output
snd_seq_midi: Unknown symbol snd_rawmidi_drain_output
snd_seq_midi: disagrees about version of symbol snd_rawmidi_input_params
snd_seq_midi: Unknown symbol snd_rawmidi_input_params
snd_seq_midi: disagrees about version of symbol snd_rawmidi_kernel_open
snd_seq_midi: Unknown symbol snd_rawmidi_kernel_open
snd_seq_midi: disagrees about version of symbol
snd_seq_create_kernel_client
snd_seq_midi: Unknown symbol snd_seq_create_kernel_client
snd_seq_midi: disagrees about version of symbol
snd_rawmidi_kernel_release

as it attempts the load the old native alsa files from the standard
kernel, because the files are missing from the 1.0.25 kmdl rom, and of
course the symbols don't match.


_______________________________________________
atrpms-devel mailing list
atrpms-devel [at] atrpms
http://lists.atrpms.net/mailman/listinfo/atrpms-devel


lemonzest at gmail

Mar 10, 2012, 2:29 PM

Post #4 of 9 (1091 views)
Permalink
Re: Alsa 1.0.25 EL6 needs rebuilding with sequencer support like 1.0.24 series/native alsa [In reply to]

Also maybe it might be a good idea to build the 1.0.25 versions of,
alsa-lib, alsa-plugins, alsa-tools, alsa-utils, alsa-oss as these might
be needed to use all features of the new upgraded kernel modules etc.

Many thanks


_______________________________________________
atrpms-devel mailing list
atrpms-devel [at] atrpms
http://lists.atrpms.net/mailman/listinfo/atrpms-devel


Axel.Thimm at ATrpms

Mar 11, 2012, 1:46 AM

Post #5 of 9 (1080 views)
Permalink
Re: Alsa 1.0.25 EL6 needs rebuilding with sequencer support like 1.0.24 series/native alsa [In reply to]

On Sat, Mar 10, 2012 at 09:57:27PM +0000, Simon Putt wrote:
> Yeah I compared the two rpms together and a number of .ko files are
> missing, like snd-midi and snd-opl3-synth which i need.

I think this is due to

--- alsa-driver-1.0.24/toplevel.config 2011-01-27 14:59:35.000000000 +0100
+++ alsa-driver-1.0.25/toplevel.config 2012-01-25 10:29:28.000000000 +0100
[...]
-CONFIG_SND_RAWMIDI_SEQ=m
-CONFIG_SND_OPL3_LIB_SEQ=m
+CONFIG_SND_RAWMIDI_SEQ=
+CONFIG_SND_OPL3_LIB_SEQ=

I can't say why this change was made. Maybe there is a new access method?
--
Axel.Thimm at ATrpms.net

_______________________________________________
atrpms-devel mailing list
atrpms-devel [at] atrpms
http://lists.atrpms.net/mailman/listinfo/atrpms-devel


lemonzest at gmail

Mar 11, 2012, 1:56 PM

Post #6 of 9 (1077 views)
Permalink
Re: Alsa 1.0.25 EL6 needs rebuilding with sequencer support like 1.0.24 series/native alsa [In reply to]

I just noticed you put up a new rpm (alsa-kdml-2.6.220.7.1 1.0.25-95)
and i compared the new and old rpm and found you had missed one line in
the spec file, this is it.

perl -pi -e's,CONFIG_SND_OPL4_LIB_SEQ= *$,CONFIG_SND_OPL4_LIB_SEQ=m,'
toplevel.config

I think this now has all the same capability as the old 1.0.24 with the
new stuff, i'm going to install now and report back.

Simon Putt


_______________________________________________
atrpms-devel mailing list
atrpms-devel [at] atrpms
http://lists.atrpms.net/mailman/listinfo/atrpms-devel


Axel.Thimm at ATrpms

Mar 11, 2012, 2:09 PM

Post #7 of 9 (1075 views)
Permalink
Re: Alsa 1.0.25 EL6 needs rebuilding with sequencer support like 1.0.24 series/native alsa [In reply to]

On Sun, Mar 11, 2012 at 08:56:02PM +0000, Simon Putt wrote:
> I just noticed you put up a new rpm (alsa-kdml-2.6.220.7.1 1.0.25-95)
> and i compared the new and old rpm and found you had missed one line in
> the spec file, this is it.
>
> perl -pi -e's,CONFIG_SND_OPL4_LIB_SEQ= *$,CONFIG_SND_OPL4_LIB_SEQ=m,'
> toplevel.config
>
> I think this now has all the same capability as the old 1.0.24 with the
> new stuff, i'm going to install now and report back.

Thanks, I was about to post about it - the configure script seems
broken (although I couldn't find the bug) and zeroes out some
modules. I forced the modules back on the build after the configure
script creates toplevel.config. A more decent debugging session would
run the configure bits with bash -x and see what went wrong, but I
don't have enough time ATM - if you want to report this upstream you
can try it. Thanks for reporting it here!
--
Axel.Thimm at ATrpms.net

_______________________________________________
atrpms-devel mailing list
atrpms-devel [at] atrpms
http://lists.atrpms.net/mailman/listinfo/atrpms-devel


lemonzest at gmail

Mar 11, 2012, 3:19 PM

Post #8 of 9 (1079 views)
Permalink
Re: Alsa 1.0.25 EL6 needs rebuilding with sequencer support like 1.0.24 series/native alsa [In reply to]

On Sun, 2012-03-11 at 22:09 +0100, Axel Thimm wrote:
> On Sun, Mar 11, 2012 at 08:56:02PM +0000, Simon Putt wrote:
> > I just noticed you put up a new rpm (alsa-kdml-2.6.220.7.1 1.0.25-95)
> > and i compared the new and old rpm and found you had missed one line in
> > the spec file, this is it.
> >
> > perl -pi -e's,CONFIG_SND_OPL4_LIB_SEQ= *$,CONFIG_SND_OPL4_LIB_SEQ=m,'
> > toplevel.config
> >
> > I think this now has all the same capability as the old 1.0.24 with the
> > new stuff, i'm going to install now and report back.
>
> Thanks, I was about to post about it - the configure script seems
> broken (although I couldn't find the bug) and zeroes out some
> modules. I forced the modules back on the build after the configure
> script creates toplevel.config. A more decent debugging session would
> run the configure bits with bash -x and see what went wrong, but I
> don't have enough time ATM - if you want to report this upstream you
> can try it. Thanks for reporting it here!

I just installed the new rpm that adds the OPL3 module back, and now my
hardware synth is working again, good work, I don't have a OPL4 card,
but I think my suggestion should work for that too, I couldn't find any
other missing sequencers in the toplevel.config.


_______________________________________________
atrpms-devel mailing list
atrpms-devel [at] atrpms
http://lists.atrpms.net/mailman/listinfo/atrpms-devel


promac at gmail

Mar 11, 2012, 9:11 PM

Post #9 of 9 (1069 views)
Permalink
Re: Alsa 1.0.25 EL6 needs rebuilding with sequencer support like 1.0.24 series/native alsa [In reply to]

On Sun, Mar 11, 2012 at 7:19 PM, Simon Putt <lemonzest [at] gmail> wrote:

> On Sun, 2012-03-11 at 22:09 +0100, Axel Thimm wrote:
> > On Sun, Mar 11, 2012 at 08:56:02PM +0000, Simon Putt wrote:
> > > I just noticed you put up a new rpm (alsa-kdml-2.6.220.7.1 1.0.25-95)
> > > and i compared the new and old rpm and found you had missed one line in
> > > the spec file, this is it.
> > >
> > > perl -pi -e's,CONFIG_SND_OPL4_LIB_SEQ= *$,CONFIG_SND_OPL4_LIB_SEQ=m,'
> > > toplevel.config
> > >
> > > I think this now has all the same capability as the old 1.0.24 with the
> > > new stuff, i'm going to install now and report back.
> >
> > Thanks, I was about to post about it - the configure script seems
> > broken (although I couldn't find the bug) and zeroes out some
> > modules. I forced the modules back on the build after the configure
> > script creates toplevel.config. A more decent debugging session would
> > run the configure bits with bash -x and see what went wrong, but I
> > don't have enough time ATM - if you want to report this upstream you
> > can try it. Thanks for reporting it here!
>
> I just installed the new rpm that adds the OPL3 module back, and now my
> hardware synth is working again, good work, I don't have a OPL4 card,
> but I think my suggestion should work for that too, I couldn't find any
> other missing sequencers in the toplevel.config.
>
>
>
Axel,

next time, can you use this .src.rpm?

I just reactivated one of old the patches.

http://people.atrpms.net/~pcavalcanti/srpms/alsa-driver-1.0.25-95.fc14.src.rpm

Thanks.


--
Paulo Roma Cavalcanti
LCG - UFRJ

atrpms devel RSS feed   Index | Next | Previous | View Threaded
 
 


Interested in having your list archived? Contact Gossamer Threads
 
  Web Applications & Managed Hosting Powered by Gossamer Threads Inc.