Login | Register For Free | Help
Search for: (Advanced)

Mailing List Archive: Apache: Users

apache httpd server 2.3.5 alpha CAN NOT load the module libphp5.so,WHY?

 

 

Apache users RSS feed   Index | Next | Previous | View Threaded


xiazhengxin at limsoft

Mar 12, 2010, 1:11 AM

Post #1 of 5 (7346 views)
Permalink
apache httpd server 2.3.5 alpha CAN NOT load the module libphp5.so,WHY?

hi,everyone.

when I run the command "apachectl start",it will give a error message:

httpd: Syntax error on line 64 of /usr/local/apache2/conf/httpd.conf:
Cannot load /usr/local/apache2/modules/libphp5.so into server:
/usr/local/apache2/modules/libphp5.so: undefined symbol: unixd_config

Line 64 in httpd.conf is "LoadModule php5_module modules/libphp5.so".

Is it a bug of 2.3.5 alpha?

here is my php configure:
$ ./configure --prefix=/usr/local/php
--with-apxs2=/usr/local/sbin/apxs --enable-mod-charset
--enable-fastcgi --with-config-file-path=/etc --enable-safe-mode
--with-openssl --with-kerberos --with-zlib --with-bz2
--enable-calendar --with-curl --enable-exif --enable-ftp --with-gd
--with-ttf --enable-mbstring --with-mcrypt --with-mhash
--with-mysql=/usr/local/mysql --enable-embedded-mysqli
--enable-sockets --enable-zip

my apache httpd configure:
$ ./configure --prefix=/usr/local/apache2 --bindir=/usr/local/bin
--sbindir=/usr/local/sbin --enable-v4-mapped --enable-maintainer-mode
--enable-file-cache --enable-cache --enable-disk-cache --enable-so
--enable-echo --enable-charset-lite --enable-mime-magic
--enable-expires --enable-headers --enable-usertrack --enable-session
--enable-session-cookie -enable-ssl --enable-http --enable-dav
--enable-info --enable-dav-fs --enable-vhost-alias --enable-imagemap
--enable-rewrite --with-included-apr

Waiting for your help,my dear friends

Best regards,
Sharl.Jimh.Tsin

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe [at] httpd
" from the digest: users-digest-unsubscribe [at] httpd
For additional commands, e-mail: users-help [at] httpd


covener at gmail

Mar 12, 2010, 3:23 AM

Post #2 of 5 (7226 views)
Permalink
Re: apache httpd server 2.3.5 alpha CAN NOT load the module libphp5.so,WHY? [In reply to]

On Fri, Mar 12, 2010 at 4:11 AM, 夏蒸鑫 <xiazhengxin [at] limsoft> wrote:
> hi,everyone.
>
> when I run the command "apachectl start",it will give a error message:
>
> httpd: Syntax error on line 64 of /usr/local/apache2/conf/httpd.conf:
> Cannot load /usr/local/apache2/modules/libphp5.so into server:
> /usr/local/apache2/modules/libphp5.so: undefined symbol: unixd_config

your php isn't aware of changes in httpd 2.3.x, namely that
"unixd_config" is renamed and moved into a module.

--
Eric Covener
covener [at] gmail

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe [at] httpd
" from the digest: users-digest-unsubscribe [at] httpd
For additional commands, e-mail: users-help [at] httpd


xiazhengxin at limsoft

Mar 12, 2010, 9:08 PM

Post #3 of 5 (7205 views)
Permalink
Re: apache httpd server 2.3.5 alpha CAN NOT load the module libphp5.so,WHY? [In reply to]

thanks for response.

what should I do now? update httpd or update php?

Best regards,
Sharl.Jimh.Tsin

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe [at] httpd
" from the digest: users-digest-unsubscribe [at] httpd
For additional commands, e-mail: users-help [at] httpd


sctemme at apache

Mar 12, 2010, 11:02 PM

Post #4 of 5 (7201 views)
Permalink
Re: apache httpd server 2.3.5 alpha CAN NOT load the module libphp5.so,WHY? [In reply to]

On Mar 12, 2010, at 9:08 PM, 夏蒸鑫 wrote:

> what should I do now? update httpd or update php?

PHP will need to be updated to support Apache HTTP Server 2.3 and 2.4. This is why we release Alphas, so module developers have an opportunity to catch up.

S.

--
Sander Temme
sctemme [at] apache
PGP FP: 51B4 8727 466A 0BC3 69F4 B7B8 B2BE BC40 1529 24AF
Attachments: smime.p7s (2.16 KB)


xiazhengxin at limsoft

Mar 13, 2010, 12:20 AM

Post #5 of 5 (7209 views)
Permalink
Re: apache httpd server 2.3.5 alpha CAN NOT load the module libphp5.so,WHY? [In reply to]

ok,I know what to do now.
thanks a lot.

Best regards,
Sharl.Jimh.Tsin

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe [at] httpd
" from the digest: users-digest-unsubscribe [at] httpd
For additional commands, e-mail: users-help [at] httpd

Apache users RSS feed   Index | Next | Previous | View Threaded
 
 


Interested in having your list archived? Contact Gossamer Threads
 
  Web Applications & Managed Hosting Powered by Gossamer Threads Inc.