Login | Register For Free | Help
Search for: (Advanced)

Mailing List Archive: Apache: Docs

[Httpd Wiki] Update of "FAQ" by TimBannister

 

 

Apache docs RSS feed   Index | Next | Previous | View Threaded


wikidiffs at apache

Jan 17, 2012, 11:38 AM

Post #1 of 1 (148 views)
Permalink
[Httpd Wiki] Update of "FAQ" by TimBannister

Dear Wiki user,

You have subscribed to a wiki page or wiki category on "Httpd Wiki" for change notification.

The "FAQ" page has been changed by TimBannister:
http://wiki.apache.org/httpd/FAQ?action=diff&rev1=30&rev2=31

Comment:
Added note about --with-included-apr and httpd 2.4.x


= C. Building Apache httpd =

- Why do I get an error about an undefined reference to "__inet_ntoa" or other __inet_* symbols?
+ == Why do I get an error about an undefined reference to "__inet_ntoa" or other __inet_* symbols? ==
If you have installed BIND-8 then this is normally due to a conflict between your include files and your libraries. BIND-8 installs its include files and libraries /usr/local/include/ and /usr/local/lib/, while the resolver that comes with your system is probably installed in /usr/include/ and /usr/lib/. If your system uses the header files in /usr/local/include/ before those in /usr/include/ but you do not use the new resolver library, then the two versions will conflict.

To resolve this, you can either make sure you use the include files and libraries that came with your system or make sure to use the new include files and libraries. Adding -lbind to the EXTRA_LDFLAGS line in your Configuration file, then re-running Configure, should resolve the problem. (Apache versions 1.2.* and earlier use EXTRA_LFLAGS instead.)
@@ -140, +140 @@

EXTRA_CFLAGS=-I/usr/local/bind/include
EXTRA_LDFLAGS=-L/usr/local/bind/lib
EXTRA_LIBS=-lbind
+
+ == I get an error about "configure failed for srclib/apr" ==
+ ''This only applies to Apache 2.4 and later''
+
+ If you are building with the --with-included-apr option, you also need to download the *-deps tarball that matches the main release that you are trying to build, and extract it into the same directory.

== Why won't Apache compile with my system's cc? ==
If the server won't compile on your system, it is probably due to one of the following causes:

---------------------------------------------------------------------
To unsubscribe, e-mail: docs-unsubscribe [at] httpd
For additional commands, e-mail: docs-help [at] httpd

Apache docs RSS feed   Index | Next | Previous | View Threaded
 
 


Interested in having your list archived? Contact Gossamer Threads
 
  Web Applications & Managed Hosting Powered by Gossamer Threads Inc.